Bug 37497 - The attribute 'transform' of the element <path> is invalid
The attribute 'transform' of the element <path> is invalid
Status: RESOLVED DUPLICATE of bug 37496
Product: Batik - Now in Jira
Classification: Unclassified
Component: SVG DOM
1.5
Other other
: P2 normal
: ---
Assigned To: Batik Developer's Mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-11-14 18:13 UTC by M.H.
Modified: 2005-11-14 09:19 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description M.H. 2005-11-14 18:13:38 UTC
On some generated SVGs I get the following exception when trying to include the 
SVG in a PDF via FOP. The SVG can be displayed correctly with an SVG viewer, so 
the SVG isn't corrupt. Unfortunately, I can't use the latest Batik as Apache 
FOP is tied to Batik 1.5 (I tried but then FOP 0.20.5 doesn't work anymore). So 
I hope to find a workaround for this bug with Batik 1.5:

svg graphic could not be built: 
file:/E:/iComps/amc/reports/7whvGXAN4boGDqySrxtwcfNAqK8eQwthsMhNqZ0ZzrQ=/C_PerfC
ons_S.svg:28
The attribute 'transform' of the element <path> is invalid 
[de.icomps.amc.bl.CaseReportClientMulti:de.icomps.xml.FOP]
                                org.apache.batik.bridge.BridgeException: 
file:/E:/iComps/amc/reports/7whvGXAN4boGDqySrxtwcfNAqK8eQwthsMhNqZ0ZzrQ=/C_PerfC
ons_S.svg:28
The attribute 'transform' of the element <path> is invalid
                                	at 
org.apache.batik.bridge.SVGUtilities.convertTransform(SVGUtilities.java:852)
                                	at 
org.apache.batik.bridge.AbstractGraphicsNodeBridge.createGraphicsNode
(AbstractGraphicsNodeBridge.java:92)
                                	at 
org.apache.batik.bridge.SVGShapeElementBridge.createGraphicsNode
(SVGShapeElementBridge.java:50)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:182)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:148)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:188)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:148)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:188)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:148)
                                	at 
org.apache.batik.bridge.GVTBuilder.build(GVTBuilder.java:120)
                                	at 
org.apache.batik.bridge.SVGImageElementBridge.createSVGImageNode
(SVGImageElementBridge.java:328)
                                	at 
org.apache.batik.bridge.SVGImageElementBridge.createGraphicsNode
(SVGImageElementBridge.java:118)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildGraphicsNode(GVTBuilder.java:182)
                                	at 
org.apache.batik.bridge.GVTBuilder.buildComposite(GVTBuilder.java:148)
                                	at 
org.apache.batik.bridge.GVTBuilder.build(GVTBuilder.java:76)
                                	at 
org.apache.fop.render.pdf.PDFRenderer.renderSVGDocument(PDFRenderer.java:590)
                                	at 
org.apache.fop.render.pdf.PDFRenderer.renderSVGArea(PDFRenderer.java:549)
                                	at org.apache.fop.svg.SVGArea.render
(SVGArea.java:98)
                                	at 
org.apache.fop.render.pdf.PDFRenderer.renderForeignObjectArea
(PDFRenderer.java:533)
                                	at 
org.apache.fop.layout.inline.ForeignObjectArea.render(ForeignObjectArea.java:89)
                                	at 
org.apache.fop.render.AbstractRenderer.renderLineArea(AbstractRenderer.java:516)
                                	at org.apache.fop.layout.LineArea.render
(LineArea.java:519)
                                	at 
org.apache.fop.render.AbstractRenderer.renderBlockArea
(AbstractRenderer.java:485)
                                	at 
org.apache.fop.layout.BlockArea.render(BlockArea.java:117)
                                	at 
org.apache.fop.render.AbstractRenderer.renderBlockArea
(AbstractRenderer.java:485)
                                	at 
org.apache.fop.layout.BlockArea.render(BlockArea.java:117)
                                	at 
org.apache.fop.render.AbstractRenderer.renderAreaContainer
(AbstractRenderer.java:451)
                                	at 
org.apache.fop.layout.AreaContainer.render(AreaContainer.java:88)
                                	at 
org.apache.fop.render.AbstractRenderer.renderAreaContainer
(AbstractRenderer.java:451)
                                	at 
org.apache.fop.layout.AreaContainer.render(AreaContainer.java:88)
                                	at 
org.apache.fop.render.AbstractRenderer.renderAreaContainer
(AbstractRenderer.java:451)
                                	at 
org.apache.fop.layout.AreaContainer.render(AreaContainer.java:88)
                                	at 
org.apache.fop.render.AbstractRenderer.renderAreaContainer
(AbstractRenderer.java:451)
                                	at 
org.apache.fop.layout.AreaContainer.render(AreaContainer.java:88)
                                	at 
org.apache.fop.render.AbstractRenderer.renderAreaContainer
(AbstractRenderer.java:451)
                                	at 
org.apache.fop.layout.ColumnArea.render(ColumnArea.java:71)
                                	at 
org.apache.fop.render.AbstractRenderer.renderSpanArea(AbstractRenderer.java:100)
                                	at org.apache.fop.layout.SpanArea.render
(SpanArea.java:94)
                                	at 
org.apache.fop.render.AbstractRenderer.renderBodyAreaContainer
(AbstractRenderer.java:368)
                                	at 
org.apache.fop.layout.BodyAreaContainer.render(BodyAreaContainer.java:137)
                                	at 
org.apache.fop.render.AbstractRenderer.renderRegions(AbstractRenderer.java:529)
                                	at 
org.apache.fop.render.pdf.PDFRenderer.renderPage(PDFRenderer.java:904)
                                	at 
org.apache.fop.render.pdf.PDFRenderer.render(PDFRenderer.java:880)
                                	at 
org.apache.fop.apps.StreamRenderer.queuePage(StreamRenderer.java:302)
                                	at 
org.apache.fop.layout.AreaTree.addPage(AreaTree.java:108)
                                	at 
org.apache.fop.fo.pagination.PageSequence.makePage(PageSequence.java:415)
                                	at 
org.apache.fop.fo.pagination.PageSequence.format(PageSequence.java:338)
                                	at 
org.apache.fop.apps.StreamRenderer.render(StreamRenderer.java:262)
                                	at 
org.apache.fop.fo.FOTreeBuilder.endElement(FOTreeBuilder.java:223)
                                	at 
org.apache.xml.serializer.ToXMLSAXHandler.endElement(ToXMLSAXHandler.java:261)
                                	at 
org.apache.xalan.templates.ElemLiteralResult.execute
(ElemLiteralResult.java:1399)
                                	at 
org.apache.xalan.transformer.TransformerImpl.executeChildTemplates
(TransformerImpl.java:2411)
                                	at 
org.apache.xalan.templates.ElemLiteralResult.execute
(ElemLiteralResult.java:1374)
                                	at 
org.apache.xalan.transformer.TransformerImpl.executeChildTemplates
(TransformerImpl.java:2411)
                                	at 
org.apache.xalan.transformer.TransformerImpl.applyTemplateToNode
(TransformerImpl.java:2281)
                                	at 
org.apache.xalan.transformer.TransformerImpl.transformNode
(TransformerImpl.java:1367)
                                	at 
org.apache.xalan.transformer.TransformerImpl.transform(TransformerImpl.java:709)
                                	at 
org.apache.xalan.transformer.TransformerImpl.transform
(TransformerImpl.java:1284)
                                	at 
org.apache.xalan.transformer.TransformerImpl.transform
(TransformerImpl.java:1262)
Comment 1 Jeremias Maerki 2005-11-14 18:19:58 UTC

*** This bug has been marked as a duplicate of 37496 ***