Bug 357 - using apache v1.3.14 with mod_jk and mod_jserv using the AJPV13 and AJPV12 connection handler. BugRat Report#638
using apache v1.3.14 with mod_jk and mod_jserv using the AJPV13 and AJPV12 co...
Status: RESOLVED DUPLICATE of bug 356
Product: Tomcat 3
Classification: Unclassified
Component: Connectors
3.2 Final
All All
: P1 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2000-12-20 15:24 UTC by Anonymous BugRat User
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomcat Developers Mailing List 2000-12-20 15:24:21 UTC
If you create a JSP page makin a <% include page="page.jsp" %> it will not correctly redirect you to newpage.jsp when using the mod_jk and mod_jserv connector(AJPV13, AJPV12). there apears the apache and SO headers and blellow the redirect page, both pages appears. This is working apache + tomcat.
the problems doesn't make with only tomcat.
there is one example in:
http://www.omega-lubricantes.com/pruebas/prueba.jsp this is well, is only the tomcat works and in the http://www.omega-lubricantes.com:8081/pruebas/prueba2.jsp is well, there is not javascript.
in the http://www.omega-lubricantes.com:8081/pruebas/prueba.jsp is working the tomcat + apache and here is the problem. doesn't redirect and appears the apache header.
the 8081 port is the apache port in this linux. The 80 port have the tomcat
the problem is in the javascript, how tha jsp compiler read the javascript. I think.
Comment 1 Dan Milstein 2001-02-13 12:34:22 UTC

*** This bug has been marked as a duplicate of 356 ***