Bug 3509 - Apache 1.3.20 & mod_webapp & Tomcat 4b7 HANGS under Win
Apache 1.3.20 & mod_webapp & Tomcat 4b7 HANGS under Win
Status: RESOLVED WONTFIX
Product: Tomcat 4
Classification: Unclassified
Component: Connector:Webapp
4.0 Beta 7
PC All
: P1 blocker with 34 votes (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 1788 4187 4211 4294 4454 4793 4807 5402 5634 6621 6896 7092 7192 7390 8433 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2001-09-07 14:54 UTC by Marcel
Modified: 2005-03-20 17:06 UTC (History)
21 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel 2001-09-07 14:54:15 UTC
I'm having big problems getting this combination to work:
- Apache 1.3.20
- mod_webapp
- Tomcat 4b7
All were recently donwloaded and installed, using defaults as much as
possible. I'm running WIndows 2K Prof SP2/JDK1.3.1.

Accessing the apache server and tomcat standalone is without problems.

In httpd.conf I added:
-----------------------
LoadModule webapp_module modules/mod_webapp.so
AddModule mod_webapp.c

WebAppConnection conn      warp  localhost:8008
WebAppDeploy     examples  conn  /examples/
WebAppInfo /webapp-info
-----------------------------

When accessing http://localhost/examples/ and clicking JSP, I'm seeing the
first 4 lines of the page, but then Tomcat hangs.

I get this error on the console:
--------------------------------
Starting service Tomcat-Standalone
Apache Tomcat/4.0-b7
Starting service Tomcat-Apache
Apache Tomcat/4.0-b7
java.lang.ArrayIndexOutOfBoundsException: No data available
        at
org.apache.catalina.connector.warp.WarpPacket.readUnsignedShort(WarpPacket.j
ava:183)
        at
org.apache.catalina.connector.warp.WarpPacket.readString(WarpPacket.java:218
)
        at
org.apache.catalina.connector.warp.WarpRequestHandler.handle(WarpRequestHand
ler.java:118)
        at
org.apache.catalina.connector.warp.WarpConnection.run(WarpConnection.java:19
4)
        at java.lang.Thread.run(Thread.java:484)
--------------------------------

There are NO errors in any of the Tomcat or Apache logs.
Comment 1 Pier Fumagalli 2001-09-07 21:18:46 UTC
Thank you Marcel for pointing this out. This issue need to be investigated 
thoughly. (Changing priority and Severity)
Comment 2 Pier Fumagalli 2001-09-07 21:21:35 UTC
*** Bug 1788 has been marked as a duplicate of this bug. ***
Comment 3 Remy Maucherat 2001-10-14 10:57:28 UTC
The bug is still unconfirmed, and it will be addressed later.
Comment 4 Pier Fumagalli 2001-10-15 13:54:54 UTC
Another report on this one by Xuemei Zhang <XZhang@ecutel.com>.
Comment 5 Pier Fumagalli 2001-10-15 14:00:02 UTC
Updating severity to Blocker. We won't have another release of WebApp 
until this one doesn't get solved.
Comment 6 Pier Fumagalli 2001-10-22 09:14:53 UTC
*** Bug 4187 has been marked as a duplicate of this bug. ***
Comment 7 Pier Fumagalli 2001-10-22 09:17:28 UTC
*** Bug 4211 has been marked as a duplicate of this bug. ***
Comment 8 Pier Fumagalli 2001-10-22 09:25:16 UTC
*** Bug 4294 has been marked as a duplicate of this bug. ***
Comment 9 Pier Fumagalli 2001-10-29 12:02:17 UTC
*** Bug 4454 has been marked as a duplicate of this bug. ***
Comment 10 Pier Fumagalli 2001-11-13 06:30:40 UTC
*** Bug 4807 has been marked as a duplicate of this bug. ***
Comment 11 Pier Fumagalli 2001-11-15 03:37:11 UTC
Someone removed the summary.
Comment 12 Christoffer Hammarstr 2001-11-17 13:35:45 UTC
I see this with Tomcat 4.0.1 too.
Comment 13 Nick 2001-12-19 05:36:36 UTC
Apache 1.3 + Tomcat 4.0.1 + mod_webapp
Tomcat 4.0.1 hangs when servlet calls url.openStream()
Comment 14 Pier Fumagalli 2001-12-31 07:21:54 UTC
*** Bug 5634 has been marked as a duplicate of this bug. ***
Comment 15 steve harrington 2002-02-16 19:36:26 UTC
Happens under Windows XP too.
Comment 16 Pier Fumagalli 2002-04-29 12:21:15 UTC
*** Bug 4793 has been marked as a duplicate of this bug. ***
Comment 17 Pier Fumagalli 2002-04-29 12:24:03 UTC
*** Bug 5402 has been marked as a duplicate of this bug. ***
Comment 18 Pier Fumagalli 2002-04-29 12:36:32 UTC
*** Bug 6621 has been marked as a duplicate of this bug. ***
Comment 19 Pier Fumagalli 2002-04-29 12:42:17 UTC
*** Bug 6896 has been marked as a duplicate of this bug. ***
Comment 20 Pier Fumagalli 2002-04-29 12:44:08 UTC
*** Bug 7092 has been marked as a duplicate of this bug. ***
Comment 21 Pier Fumagalli 2002-04-29 12:45:52 UTC
*** Bug 7192 has been marked as a duplicate of this bug. ***
Comment 22 Pier Fumagalli 2002-04-29 12:47:47 UTC
*** Bug 7390 has been marked as a duplicate of this bug. ***
Comment 23 Pier Fumagalli 2002-04-29 12:51:48 UTC
*** Bug 8433 has been marked as a duplicate of this bug. ***
Comment 24 corey innis 2002-05-09 01:09:37 UTC
Don't know if this will help at all.

with Apache 1.3.24 + Tomcat 4.0.3 + mod_webapp ( 20020506 ) on Linux 7.2 with 
glibc2.2:

[org.apache.catalina.connector.warp.WarpConnection] Exception on socket
java.io.IOException: Premature packet header end
        at org.apache.catalina.connector.warp.WarpConnection.recv
(WarpConnection.java:237)
        at org.apache.catalina.connector.warp.WarpRequestHandler.handle
(WarpRequestHandler.java:112)
        at org.apache.catalina.connector.warp.WarpConnection.run
(WarpConnection.java:194)
        at java.lang.Thread.run(Thread.java:479)


Some debugging discoveries:
- seems to happen regularly with Opera and NS6 clients
- seldom ( ever? ) with IE or NS4
- packet.getType() returns -1 ( in WarpConnection.recv() ) at that time. This 
appears to happen after the request has (otherwise) been successfully 
processed... WarpConnection.recv(packet) is called with packet.getType() = 
Constants.TYPE_REQ_PROCEED; a few seconds ( 2-15 ) later WarpConnection.recv
(packet) called with packet.getType() = -1.


corey
Comment 25 Remy Maucherat 2003-04-15 15:40:01 UTC
The webapp connector has been deprecated due to lack of developer iterest (the 
community felt that JK 2 was a more compelling solution). The webapp connector 
should not be used on Windows.