Bug 35059 - RuntimeController not working correctly
RuntimeController not working correctly
Status: CLOSED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
2.0.3
Other Linux
: P2 major (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-05-25 13:24 UTC by Andrzej Kondracki
Modified: 2011-09-08 07:05 UTC (History)
0 users



Attachments
Test plan that shows issue is fixed in TRUNK (5.72 KB, application/octet-stream)
2011-09-07 20:02 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrzej Kondracki 2005-05-25 13:24:35 UTC
since 2.0.3 the RuntimeController stopped working correclty, in the following
configuration:
ThreadGroup
  + RuntimeController
    + LoopController (forever)

the inner LoopController does not stop after the time specified in the
containing RuntimeController. This seems to be a result of the recent change in
the isDone, to me it looks that the endOfLoop should be checked there first,
before the other conditions.
Comment 1 Sebb 2005-06-17 02:09:46 UTC
Some code fixes have been applied to CVS Head, which seem to fix it.

The current nightly build contains the fix if you want to try it.
Comment 2 Mike Stover 2005-06-30 19:21:06 UTC
Can anyone specify exactly what the Runtime should do?  It's current behavior,
even with this change, strikes me as problematic.
Comment 3 Philippe Mouawad 2011-09-07 20:02:37 UTC
Created attachment 27470 [details]
Test plan that shows issue is fixed in TRUNK
Comment 4 Philippe Mouawad 2011-09-07 20:04:09 UTC
I think issue is fixed since a while, but I submitted a Test case to show it is fixed.
I tested on 2.4 and Trunk and it is ok
Philippe Mouawad
Comment 5 Milamber 2011-09-08 07:05:38 UTC
In your test plan, Loop controller must have Loop count to Forever to reproduce this bug.

I confirme with lastest JMeter (2.5) this bug is fixed. (with a same test plan, I can reproduce this with old 2.0.3, but not with 2.5)

Thanks.