Bug 34654 - ZipException when using "tag" in deployer
ZipException when using "tag" in deployer
Status: RESOLVED WORKSFORME
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.5.9
Other other
: P2 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-04-28 00:45 UTC by Henri Dupre
Modified: 2005-10-25 08:14 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henri Dupre 2005-04-28 00:45:23 UTC
<deploy url="https://myurl..." username="..." password="..." path="/app"
war="${basedir}/${app.name}-${build.number}.war" />
works perfectly. I tried to use a tag and used
    <deploy url="https://myurl..." username="..." password="..." path="/app"
war="${basedir}/${app.name}-${build.number}.war"
tag="build-${build.number}-${DSTAMP}"/>
This causes serious issues on tomcat. Tried it with Sun jdk 1.5 and BEA's JDK
1.5 and same zipexception


INFO: Manager: Uploading WAR file to
/opt/web/clients/a/actualis/catalina/work/Catalina/localhost/manager/build-21-20050428/app.war
28 avr. 2005 01:25:21 org.apache.catalina.startup.HostConfig deployWAR
INFO: Déploiement de l'archive app.war de l'application web
28 avr. 2005 01:25:21 org.apache.catalina.startup.ContextConfig init
GRAVE: Exception fixing docBase: {0}
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:204)
        at java.util.jar.JarFile.<init>(JarFile.java:132)
        at java.util.jar.JarFile.<init>(JarFile.java:70)
        at sun.net.www.protocol.jar.URLJarFile.<init>(URLJarFile.java:56)
        at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:41)
        at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:68)
        at
sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:102)
        at
sun.net.www.protocol.jar.JarURLConnection.getJarFile(JarURLConnection.java:69)
        at org.apache.catalina.startup.ExpandWar.expand(ExpandWar.java:140)
...
GRAVE: Erreur lors du démarrage des Resources statiques
java.lang.IllegalArgumentException: Fichier WAR invalide ou illisible  : error
in opening zip file
        at
org.apache.naming.resources.WARDirContext.setDocBase(WARDirContext.java:134)
        at
org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3754)
        at org.apache.catalina.core.StandardContext.start(StandardContext.java:3925)
        at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524)
        at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:788)
        at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:498)
Comment 1 Henri Dupre 2005-04-28 00:49:38 UTC
The really strange thing is that I looked at the jar file uploaded and it seems
valid. I can unzip it without any issues.
Comment 2 Yoav Shapira 2005-06-01 04:12:33 UTC
I can't reproduce this, and since neither can you (if I understand your note
correctly), I'm closing this item.
Comment 3 Haroon Rafique 2005-10-25 16:14:25 UTC
Henri, has your problem been fixed? Can you look at bug 36847 to see if that
fixes your problem?