Bug 34586 - XPath Assertion seems to always use "/" as the xpath expression?
XPath Assertion seems to always use "/" as the xpath expression?
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.0.3
Other Windows XP
: P3 minor (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 37163 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-04-22 22:59 UTC by Mark Keenan
Modified: 2005-10-19 17:49 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Keenan 2005-04-22 22:59:25 UTC
When loading a test plan which has an "XPath Assertion" element, it seems the 
XPath string (there is no label for it in the GUI, it's the text box to the 
left of the "Validate" button) is always set to "/".

More importantly however, It seems that nothing that is typed into this text 
box takes effect. I added a System.out.println statement to line 122 of 
XPathAssertion.java in order to see the value of "getXPathString()", and it 
was "/" even though I had typed a different expression into the text field.

This is my first ever Bugzilla report, so please be gentle in your 
admonishment of me if I have not filled in this form correctly :-)
Comment 1 Mark Keenan 2005-04-22 23:37:17 UTC
I have added System.out.println() statements to XPathAssertion.java, 
XPathAssertionGui.java, and XPathPanel.java to try to help track this down.  
In all cases when I print the value of the XPath expression it is the 
default: "/".

I don't know if that helps, but _to me_ it looks like the value of the xpath 
expression is never being read from the text box.
Comment 2 Sebb 2005-04-23 01:57:41 UTC
It is being read from the text box - however the text box on screen is not the
one that it is being read!

Fixed in CVS (HEAD)
Comment 3 Sebb 2005-10-20 01:49:28 UTC
*** Bug 37163 has been marked as a duplicate of this bug. ***