Bug 34182 - Modifying Excel file using Event Model
Modifying Excel file using Event Model
Status: RESOLVED INVALID
Product: POI
Classification: Unclassified
Component: POIFS
2.5
Other other
: P2 critical (vote)
: ---
Assigned To: POI Developers List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-03-25 19:02 UTC by Raju
Modified: 2005-04-04 09:04 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raju 2005-03-25 19:02:24 UTC
I am using the even model to read the large files and writing into a different 
file. I would like to know whether i can modify the excel file using event 
model or not.
I modified the ReaderWriter.java and getting the workbook as stream. From the 
stream i created Records and created workbook object. I would like know 
whether i can modify the Record objects and write it back to the workbook 
stream.
I am able to write and modify the excel files using HSSFWorkbook. Due to 
memory concerns we are getting OutOfMemory errors. We are not in a position to 
increase the memory. So i am trying to make use of low level API to write the 
excel file.
Please let me know if anyone has done some research in modifying the excel 
file using Event Model API.
Thanks in advance
Comment 1 Andy Oliver 2005-04-04 17:04:45 UTC
not a bug, do not use bugzilla to ask questions (we have mail lists for that)