Bug 34134 - Tomcat 5.5.6 Jasper ant task does not find JSTL TLDs
Tomcat 5.5.6 Jasper ant task does not find JSTL TLDs
Status: RESOLVED DUPLICATE of bug 33373
Product: Tomcat 5
Classification: Unclassified
Component: Jasper
5.5.6
Other other
: P2 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-03-22 19:08 UTC by Cris Daniluk
Modified: 2005-03-22 10:47 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cris Daniluk 2005-03-22 19:08:33 UTC
Following ant snippet does not succeed with Tomcat 5.5.6:

  <taskdef classname="org.apache.jasper.JspC" name="jasper2" >
    <classpath refid="global.classpath" />
    <classpath refid="project.classpath" />
  </taskdef>

  <target name="jspc">
    <mkdir dir="${glin.buildjsp}" />
    <jasper2
             validateXml="false"
             uriroot="${glin.web}/docroot"
             webXmlFragment="${glin.web}/docroot/WEB-INF/jsp_web.xml"
             outputDir="${glin.buildjsp}" />
...


global.classpath contains a reference to tomcat 5.5.6. project.classpath
constitutes all of the project libs, including standard.jar. When executing, I
receive the following error:

org.apache.jasper.JasperException: The absolute uri:
http://java.sun.com/jsp/jstl/core cannot be resolved in either web.xml or the
jar files deployed with this application
        at
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:50)
        at
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407)
        at
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:114)
        at
org.apache.jasper.compiler.TagLibraryInfoImpl.generateTLDLocation(TagLibraryInfoImpl.java:316)
        at
org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:147)
        at org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:418)
...

However, this TLD is included in standard.jar. The web.xml has no TLD
references, but it is a 2.4 compliant webapp. If I change to point to Tomcat
5.0.x, everything works fine. I am running JDK1.5, though I can reproduce this
behavior on 1.4.2.
Comment 1 Remy Maucherat 2005-03-22 19:47:30 UTC

*** This bug has been marked as a duplicate of 33373 ***