Bug 33314 - [Kupu] Allow editing of additional XML elements
[Kupu] Allow editing of additional XML elements
Status: RESOLVED WONTFIX
Product: Lenya
Classification: Unclassified
Component: Kupu Integration
Trunk
PC Windows XP
: P2 enhancement
: 2.0.1
Assigned To: Lenya Developers
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-01-31 17:39 UTC by Gregor J. Rothfuss
Modified: 2010-07-13 11:46 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor J. Rothfuss 2005-01-31 17:39:23 UTC
it's a long-standing request to be able to use addional xml elements in kupu.
this allows to combine the cross-browser features of kupu with a xhtml+ schema

this now seems possible. i have copied a conversation from the kupu IRC channel
below:

gregor	i was wondering.. does kupu still strip out unknown xml tags?
guido_w	gregor: we have a very nice new, configurable filter now, so if you want
to it won't...
guido_w	however i can't guarantee editability (?) of the document if you put in
non-HTML tags
guido_w	gregor: i did write a cool extension for some customer of ours, which
allows using 'replacement elements' for non-HTML elements
guido_w	you will have to do the actual replacing on the server, but it does
allow you to *manage* non-HTML structures from a Kupu tool, if you create an
element with that tool it will generate some special HTML markup with values set
as attributes
guido_w	and it's all configurable from XML, so you can add new forms,
validations and replacement structures from XML
guido_w	gregor: svn co http://codespeak.net/svn/kupu/tools/genericelements/ i think
gregor	thanks for the info. i will replicate it to the lenya mailing list as it
is a FAQ :)

we should improve the kupu integration to use these features. this means
shipping with support for lenya:meta, and making it easy to add your own
handlers for other xml elements.
Comment 1 Manos Batsis 2005-08-23 16:00:39 UTC
This would allow XDoc editing within kupu BTW. 
Comment 2 Richard Frovarp 2010-07-13 11:46:28 UTC
Kupu will not be supported in future versions.