Bug 32709 - Memory Leak in Manager Start/Stop
Memory Leak in Manager Start/Stop
Status: RESOLVED DUPLICATE of bug 26135
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Manager
5.0.30
PC Linux
: P3 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-12-15 00:15 UTC by James Norman
Modified: 2004-12-14 15:40 UTC (History)
0 users



Attachments
Use this java class to start/stop webapps until OOMError happens (2.42 KB, text/plain)
2004-12-15 00:26 UTC, James Norman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Norman 2004-12-15 00:15:02 UTC
I have observed a memory leak in the Tomcat manager when starting/stoping a web
application.  With a simple web application (struts-examples) I am allowed ~110
start/stop's through the manager before I get an OutOfMemoryException.  I
believe that this is realted to bug 20758 which is marked as resolved. 
 
My environment:
OS: Fedora Core 2
JDK Build: build 1.4.2_05-b04
Tomcat 5.0.30
Comment 1 James Norman 2004-12-15 00:26:04 UTC
Created attachment 13756 [details]
Use this java class to start/stop webapps until OOMError happens

Use this java class to do rapid start/stop's of a web application to produce an
OutOfMemoryError.  You will need to change the package and the SERVER field in
the class.  Also, since this does not deal with authentication, you will need
to remove the authentication attributes for the manager application.  This is
done by commenting the <resource-env-ref>, <security-constraint>,
<login-config> and <security-role> tags in
CATALINA_HOME/server/webapps/manager/WEB-INF/web.xml
Comment 2 James Norman 2004-12-15 00:30:44 UTC
I am not able to attach the struts-examples.war web application, it is 10k to
large for bugzilla.  You can download struts from:
http://mirror.candidhosting.com/apache/struts/binaries/jakarta-struts-1.2.4.tar.gz
Extract the file webapps/struts-examples.war

Use this web application in conjunction with the attached file:
WebPageConnector.java to reproduce the bug.  Deploy the struts-examples.war
application, then run the WebPageConnector, and the OutOfMemoryError will be
reproduced.
Comment 3 Remy Maucherat 2004-12-15 00:40:43 UTC

*** This bug has been marked as a duplicate of 26135 ***