Bug 31765 - Apache can not start in MS Winxp Service Pack 2
Apache can not start in MS Winxp Service Pack 2
Status: RESOLVED WONTFIX
Product: Apache httpd-2
Classification: Unclassified
Component: Core
2.0-HEAD
PC Windows XP
: P1 critical with 6 votes (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
: 31957 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-10-19 02:07 UTC by ahe
Modified: 2014-01-19 23:58 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ahe 2004-10-19 02:07:33 UTC
When started as a NT service or console, the apache process hanged. In the 
Error log error.log, there are looped messages AS FOLLOWS:
 "[Tue Oct 19 08:35:52 2004] [notice] Parent: Created child process 2032
[Tue Oct 19 08:35:52 2004] [notice] Child 2032: Child process is running
[Tue Oct 19 08:35:52 2004] [crit] (OS 10022)An invalid argument was 
supplied.  : Child 2032: setup_inherited_listeners(), WSASocket failed to open 
the inherited socket.
[Tue Oct 19 08:35:52 2004] [error] Parent: child process exited with status 3 -
- Aborting.
[Tue Oct 19 08:35:52 2004] [notice] Parent: Created child process 3908"
Comment 1 Roland 2004-10-19 08:54:19 UTC
I have problems after I installed Windows Xp (home) Service Pack 2 (SP2).
Since then Apache 'hangs' randomly, wich means : sometimes it takes hours to 
crash and sometimes a day. I have to restart my PC everytime to get it right 
again.
It is not the new Windows firewall in SP2, it is not Zonealarm and it is not 
Norton Antivirus 2005 who cause it. I tried them all turning them off 
seperately.
What does SP2 do to Apache (the lastest version) ?!
I seached other topics about this problem and I found none (except the one of 
Windows2000). Am I the only one who's got this huge problem with XP SP2 ?
Comment 2 ahe 2004-10-21 00:02:05 UTC
In addition, I meet the problem above mentioned in Windows Xp Professional 
Sp2. In my Winxp Home Sp2, the Apache server Random Hangs as Roland said, what 
happened?
Comment 3 bernard 2004-10-21 14:34:41 UTC
Not just you.

Definately Apache (however installed) is flaky after service pack 2 installed 
(had working server before SP2). Done everything bar uninstalling SP2. Multiple 
uninstalls / reinstalls of multiple flavours of Apache 2 (both from apache.org 
and various wamps). Not tried 1.3 (so that soon).

Windows XP (home + SP2). Server always runs, html page returned, but either 
will fail to display most (but not all) gfx (jpg/gif)/ css or will only respond 
to bizarre rearrangements of local url. Pattern is elusive.

e.g. one install (sorry forget which, possibly devside wamp) eventually worked 
with http://127.0.0.1 but not localhost unless a local url which was in reality 
localhost/samples/ was entered as localhost/SAMPLES. i.e. case sensitive, but 
upside down. Best clue I can offer. Hope you can apply keener brains than mine 
tothe prob.

P.S. There are 2 other bug reports: 31022 31259. Is anyone addressing this 
issue?

Bernard
Comment 4 Roland 2004-10-25 18:50:42 UTC
Problem still excists. Now I am running under ABYSS WEBSERVER X1.
Couldn't wait longer cause visitors got irritated about the randomly offline 
issue.
Hope this will survive XP SERVICE PACK 2 (SUXXX)

Roland
Comment 5 Jeff Trawick 2004-10-26 11:03:37 UTC
Apache/XP-SP2 interaction problem isn't resolved; re-opening
Comment 6 ahe 2004-11-01 06:35:47 UTC
Tried in Apache 1.3, same problem, does Apache Group read bugzilla and try to 
resolve it?
Comment 7 Joe Orton 2004-11-02 23:38:12 UTC
*** Bug 31957 has been marked as a duplicate of this bug. ***
Comment 8 Claudio Stramaglia 2006-02-10 16:07:19 UTC
uncheck the "Enable LMHOSTS Lookup" box in your TCP/IP protocol setup and
everything will be OK

(In reply to comment #0)
> When started as a NT service or console, the apache process hanged. In the 
> Error log error.log, there are looped messages AS FOLLOWS:
>  "[Tue Oct 19 08:35:52 2004] [notice] Parent: Created child process 2032
> [Tue Oct 19 08:35:52 2004] [notice] Child 2032: Child process is running
> [Tue Oct 19 08:35:52 2004] [crit] (OS 10022)An invalid argument was 
> supplied.  : Child 2032: setup_inherited_listeners(), WSASocket failed to open 
> the inherited socket.
> [Tue Oct 19 08:35:52 2004] [error] Parent: child process exited with status 3 -
> - Aborting.
> [Tue Oct 19 08:35:52 2004] [notice] Parent: Created child process 3908"

Comment 9 Russell Preston 2006-03-02 12:47:37 UTC
I disagree - I have tried this and the problem is not resolved!  Can anyone
confirm this solution has worked for them or not?   I am still struggling with
this issue.

(In reply to comment #8)
> uncheck the "Enable LMHOSTS Lookup" box in your TCP/IP protocol setup and
> everything will be OK
Comment 10 William A. Rowe Jr. 2006-03-02 16:03:52 UTC
> Tried in Apache 1.3, same problem, 

That's quite bad news; Apache 1.3 was much 'simpler' in using socket I/O, and
system calls.  It didn't take advantage of any 'features' specific to Windows.

"antispyware" "antivirus" "firewall" applications can all interfere with a
-server- such as httpd.  Port 80 or your port of choice must be unblocked,
and those program's bugs affect apache.  Many insert themselves into the
sockets layer; then do not support the entire sockets API correctly causing
other applications to misbehave.  Microsoft Netmeeting seems to trip over many
of the same drivers and utilities that interfere with Apache HTTP server.

I would list the usual corrections to DisableWin32AcceptEx, EnableMMAP off,
and EnableSendfile off.  But if Apache 1.3 also fails, this is not promising.

> does Apache Group read bugzilla 

yes

> and try to resolve it?

no

Nothing's written here to tell us what's specifically wrong with the program.
Me, personally?  I won't run MS Crippleware such as XP Home, so really can't
reproduce this problem myself.  I don't see this problem on XP Pro SP2.

Try uninstalling the various antispyware/antivirus/firewall programs you have
installed, one at a time, reboot each time.  Report back which program caused
you this interference.

Comment 11 Vlad Alexa Mancini 2006-03-19 09:40:15 UTC
Can see http://apache2triad.net/forums/viewtopic.php?t=2718 for more reports 
and info on the issue
Comment 12 Fayland Lam 2006-03-20 01:57:58 UTC
ok, I have tried something like this:

start Apache2
open 'TCP/IP'->WINS->Disable NetBIOS(if it's disabled, just try set this to
default)a
and u'll find the CPU drops.

I think it's something wrong with your sofeware. it occurs when I start software
Dr.com.

try it.
Comment 13 William A. Rowe Jr. 2006-03-20 07:19:50 UTC
"An invalid argument was supplied.  : Child 2032: setup_inherited_listeners(), 
WSASocket failed to open the inherited socket."

Tells me you have something, even an intregal part of the Windows OS, which has
not correctly implemented the Winsock.dll interface.  Examples of possible
offenders include antivirus, vpn or even network hardware drivers.

Since your software isn't implementing the win32 api correctly, there's nothing
we can do to help you; take your question to an appropriate user support forum,
this resource is for solving bugs in the -Apache- software.
Comment 14 Ozcan 2006-04-12 16:22:12 UTC
(In reply to comment #13)
> "An invalid argument was supplied.  : Child 2032: setup_inherited_listeners
(), 
> WSASocket failed to open the inherited socket."
> Tells me you have something, even an intregal part of the Windows OS, which 
has
> not correctly implemented the Winsock.dll interface.  Examples of possible
> offenders include antivirus, vpn or even network hardware drivers.
> Since your software isn't implementing the win32 api correctly, there's 
nothing
> we can do to help you; take your question to an appropriate user support 
forum,
> this resource is for solving bugs in the -Apache- software.

I verify that the above comment is "true and correct".

Folks, I've spent a day trying to figure out this problem.

The problem is most likely related to a personal firewall and or virus scanner. 
Killing your firewall process does not remedy the problem, try uninstalling it 
and then testing it.

I have 2 PSc having the same problem. Both computers are using different virus 
scanners and different personal Firewalls.

I've uninstalled both virus scanner and Firewall from my laptop and wolla the 
problem disappeared.

Comment 15 NETcsabi 2006-06-12 22:46:49 UTC
(In reply to comment #9)
> I disagree - I have tried this and the problem is not resolved!  Can anyone
> confirm this solution has worked for them or not?   I am still struggling with
> this issue.
> 
> (In reply to comment #8)
> > uncheck the "Enable LMHOSTS Lookup" box in your TCP/IP protocol setup and
> > everything will be OK

I just dont understand that how SP2 can mess up things that much... Stupid me...

I ran into this problemtoo:

1) Apache2 was working fine.
2) Installed SP2
3) Apache crashed: Apache shows it is started, but I cannot connect to it. It
just hangs over, waiting...
4) Tried the "LMHOSTS trick" -> I disabled LMHOSTS Lookup
5) Apache worked
6) After a reboot it crashed again. (Same behaviour)
7) OK. What can I lose? I enabled LMHOSTS Lookup back again.
8) Now. Apache is working...

And now I am uninstalling SP2.

And ASAP I switch back to Linux.
Comment 16 Mike 2006-06-30 07:43:40 UTC
(In reply to comment #13)
 
> Since your software isn't implementing the win32 api correctly, there's nothing
> we can do to help you; take your question to an appropriate user support forum,
> this resource is for solving bugs in the -Apache- software.

OK, but how come other software is able to create a listening socket even with
the same antivirus/firewall software installed? I recently installed UltraVNC
and it works fine. Also MySQL works great as well. And Apache seems to be the
only one that is having problems with using the Win32 API - so perhaps this
still is Apache bug?

Comment 17 Matt 2006-09-26 20:31:29 UTC
"Since your software isn't implementing the win32 api correctly, there's nothing
we can do to help you; take your question to an appropriate user support forum,
this resource is for solving bugs in the -Apache- software."

This is lameness. Other apps can open sockets just fine without digging 3 levels
deep into time-forgotten tcp/ip dialogs to tweak things most people have never
seen and should not need to change to get a simple webserver running, so what's
your excuse? I walk through the msi, and unless I've done something wonky to my
network or settings, the daemon should not crash using a distro configuration.
Someone with less time or patience would assume the software just doesn't work
and move on.

In this case, the only other software not implementing apis correctly would be
windows itself, and I know what MS would say if people came whining to them
about this bug... "apache who?" Please be the bigger developer and document this
problem up front. (I've noticed php bugs of this nature are copped-out-of in the
same way. If they can't figure it out or don't want to be bothered with it, they
pass blame instead of making a simple note where people can find it.)

I have unchecked said box, and things appear to be working for now.
Comment 18 William A. Rowe Jr. 2006-09-26 20:45:34 UTC
If you took this to the user forum, you would discover that DisableWin32AcceptEx,
EnableSendfile off and EnableMMap off --- disabling every acceleration that the
Apache software uses --- solves the bug in your software.

Everywhere you see "Apache fails to..." you will find corresponding reports
that "Netmeeting fails to..."

we aren't the only ones using the accelerated APIs folks.

But this bugtracking system is for tracking bugs and not for diagosing problems,
it's for correlating bugs to their solutions.  The solution exists, this bug
is closed, please keep your questions on the appropriate forum.  That includes
PHP - we don't create that so we won't address that.

Comment 19 ahe 2006-09-28 08:49:02 UTC
Forget that, I tried all solutions above and does not work, so I give up the 
APACHE. thank u all.
Comment 20 Remy Williams 2006-11-03 20:11:55 UTC
I was able to get my apache running again by reseting the winsock catalog using 
the net shell command. I would warn people that if you do not have your 
firewalls, anti-virus, anti-spyware, etc, etc turned off when you do the 
command then it will render them impotent. they will still show up and say that 
they are working but not be protecting. 
For this reason i am not going to list the command here but for those that 
would like to try this and see if it fixes for them as well, you can go to 
support.microsoft.com and do a search for winsock reset and the instructions 
should be the first result and within it click on: Manual steps to recover from 
Winsock2 corruption.

**Please note that even on the support site they state:
Warning Programs that access or monitor the Internet such as antivirus, 
firewall, or proxy clients may be negatively affected when you run the winsock 
reset command. If you have a program that no longer functions correctly after 
you use this resolution, reinstall the program to restore functionality.**

Good luck and i hope this helps others as well.
Comment 21 wajdi 2012-01-16 09:38:45 UTC
appache can't start and in error log file i retrive this message :
Child 5300: setup_inherited_listeners(), WSASocket failed to open the inherited socket
Comment 22 Martin Mugweru 2012-10-18 11:38:25 UTC
"An invalid argument was supplied. : Child 4076: setup_inherited_listeners(), WSASocket failed to open the inherited socket"

This is something that appears to have been there for a while and am stuck in this murky thing. Am running winXP with SP3 on a Thinkpad. I have un installed my antivirus, and other services. Initially I was running wamp for a couple of years then, from no where, on a bizarre day it started reporting this error. I tried uninstalling and installing different versions of wamps and httpds all in vain. Now am trying httpd-2.2.21-win32-x86-no_ssl but still am stuck. 

SOMEBODY HEEELLLLP!!!!!.

I have played around with LMHOSTS and NETBIOS tricks and yielded nothing. I wonder is it something Apache has ignored since 2006 or the implementation is just bugy or there is a secret weapon hidden some where? Restoring my machine seam to be the last option at the expense of buying restore CDs, surely.
Comment 23 Eric Covener 2014-01-19 23:58:00 UTC
XP and 2.0 are both out of mainstream support and this bug clearly isn't going anywhere.