Bug 30120 - Name of simple controller is resetted if a new simple controller is added as child
Name of simple controller is resetted if a new simple controller is added as ...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.0.1
PC All
: P3 minor with 2 votes (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-07-15 12:51 UTC by Nicoletta John
Modified: 2007-05-08 04:32 UTC (History)
0 users



Attachments
Suggested patch (5.51 KB, patch)
2007-05-03 03:15 UTC, Alf Hogemark
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nicoletta John 2004-07-15 12:51:23 UTC
Name of simple controller is resetted if a new simple controller is added as 
child.
Comment 1 Sebb 2005-02-18 04:32:29 UTC
Same applies to other Controllers, e.g. Loop. However, if a different controller
is added as a child, the name is not affected.

Nor is the name affected if the controller is dragged and dropped as a child.
Comment 2 Peter Lambrechtsen 2006-08-06 09:38:38 UTC
If a Module Controller is linked to a simple controller and you create a new
simple controller then the module controller will change the link to "Simple
Controller" 
Comment 3 Alf Hogemark 2007-05-03 03:15:07 UTC
Created attachment 20114 [details]
Suggested patch

The change in GUIPackage is the same as suggested in bug 39427.

The change in AddToTree is to make the adding of items use the same code as the
ProxyControl for example, uses to add items to the test plan.

The change in AbstractJMeterGuiComponent is to clear the value of the
"comment", so that when a new item of a gui class that is already added to the
plan, the new item gets an empty comment, and not the same comment as another
item in the test plan.
Comment 4 Alf Hogemark 2007-05-03 03:15:53 UTC
(In reply to comment #3)
Note that this patch also solves bug 41078, since it is really the same problem
in that bug.
Comment 5 Sebb 2007-05-04 02:07:33 UTC
Thanks very much for fixing this long standing bug.

Added to SVN in r535134.
Comment 6 Peter Lambrechtsen 2007-05-07 21:16:16 UTC
Thanks for fixing the bug, will check out the latest SVN release and compile it
and see if the problem is fixed.  Many thanks for this.
Comment 7 Sebb 2007-05-08 04:32:48 UTC
No need to compile it yourself unless you want to.

I did a new nightly build recently - r535921 - which will include the fix.