Bug 29853 - Regular Expression Extractor GUI does not load and run JMX file settings correctly
Regular Expression Extractor GUI does not load and run JMX file settings corr...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: HTTP
2.0.1
All other
: P3 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 31141 31321 31479 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-06-29 01:23 UTC by Mabel Chow
Modified: 2004-11-16 19:05 UTC (History)
4 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mabel Chow 2004-06-29 01:23:25 UTC
Overview Description:
=====================
The Regular Expression Extractor GUI displays option to check in Body or 
Header. 
When you have more than one of these elements and each has different response 
field 
to check, the GUI displays them all as the first element checked value.
This happens after you save the script, exit, and reopen the script.

When running the test, all the Extractors has the same response field value.
Have to manually change the values before test is run.

Steps to Reproduce:
===================
Create a Regular Expression Extractor with option to check the Header on a
HTTP Request.

Create a second Regular Expression Extractor on another HTTP Request with 
option 
to check the Body.

Save your test plan.

Run it once. Note that the extractors are getting the correct values from the 
correct response type.

Save your test plan just to be sure.

Close the test plan.

Reopen the test plan.

Run the test.


Actual Results:
===============
After running the test the second time, the extractors are now not getting 
the correct values.  Also if you look at the second extractor which should be 
set to Body, it is now set to Header.


Expected Results: 
=================
The Extractor response field values should be loaded correctly since when 
looking 
at the JMX file, the values are saved correctly.  It isn't displayed correctly 
nor 
is it run with the correct values.


Build Date & Platform: 
======================
JMeter 2.0.1 and June 12 nightly build.


Additional Information:
=======================
Running in non-gui mode behaves correctly as expected. 
This radio-button oddity seems to also apply to Results Status Action Handler 
element.
Comment 1 Sebb 2004-07-01 23:32:12 UTC
Thanks for the report.

Checked in a fix to the rel 2.0 branch and HEAD for Regex and Result Status 
action GUI elements.

Closing call - please reopen if there are still problems.
Comment 2 Sebb 2004-09-13 17:03:14 UTC
*** Bug 31141 has been marked as a duplicate of this bug. ***
Comment 3 Sebb 2004-09-20 23:49:09 UTC
*** Bug 12144 has been marked as a duplicate of this bug. ***
Comment 4 Sebb 2004-09-20 23:51:22 UTC
*** Bug 31321 has been marked as a duplicate of this bug. ***
Comment 5 Sebb 2004-09-30 22:58:52 UTC
*** Bug 31479 has been marked as a duplicate of this bug. ***