Bug 29186 - Can't control remote hosts with dashes in the host names
Can't control remote hosts with dashes in the host names
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
1.9.1
All other
: P3 normal (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 33299 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-05-24 19:59 UTC by Tommy Johnson
Modified: 2005-02-20 15:59 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy Johnson 2004-05-24 19:59:14 UTC
I am running JMeter in server mode on several NT boxes, and the console/GUI 
controller on a Sun Solaris box.  When starting the console instance I pass 
this parameter:

-Jremote_hosts=test3k,w3kdc,jm1-2003,jm3-2003

...but when I go to Start Remote Hosts it lists only test3k, w3kdc and jm1.  
Seems to have trouble parsing the dash "-" in the third machine name.
Comment 1 Sebb 2004-05-24 23:53:02 UTC
This appears to be a problem in the handling of command-line arguments by 
org.apache.avalon.excalibur.cli.CLArgsParser, which may make it tricky to 
fix...
Comment 2 Sebb 2005-02-21 00:57:53 UTC
*** Bug 33299 has been marked as a duplicate of this bug. ***
Comment 3 Sebb 2005-02-21 00:59:42 UTC
Fixed in branch 2.0 (imported copy of Avalon CLI source, and fixed the bug)