Bug 28000 - Enabling mod_usertrack results in Segmentation fault (11)
Enabling mod_usertrack results in Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 24483
Product: Apache httpd-1.3
Classification: Unclassified
Component: Other mods
1.3.29
PC FreeBSD
: P3 critical (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-03-28 00:41 UTC by Holger Kipp
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Kipp 2004-03-28 00:41:19 UTC
I have installed the following:

apache13-modssl on FreeBSD 5.2.1 and 5.2-CURRENT (from 27.04.2004, 22:00 CET),
additionally mod_gzip and mod_php4.

Every call that is involving a Cookie (Type Netscape or Cookie, not Cookie2)
results in the following error (nothing else, even with loglevel debug):

[Sat Mar 27 15:35:39 2004] [notice] child pid 23732 exit signal Segmentation
fault (11)

Problem exists with CookieTracking on
and does _not_ exist with CookieTracking off

php4 and oracle-connect work like a charm, external cgi with perl as well, even
mod_ssl and compressing the data with mod_gzip does work without any problems.

The same setup works without problems on FreeBSD 4.x-STABLE with slightly older
apache13-modssl-installation.

Please let me know if or how I should provide additional information,
eg truss or ktrace.

Regards,
Holger Kipp
Comment 1 André Malo 2004-03-28 00:48:45 UTC
Please have a look at http://httpd.apache.org, the problem and a workaround is
described on our front page ;-)

*** This bug has been marked as a duplicate of 24483 ***