Bug 27888 - apachebench reports length errors for dynamic pages
apachebench reports length errors for dynamic pages
Status: RESOLVED WONTFIX
Product: Apache httpd-1.3
Classification: Unclassified
Component: Other
1.3.29
Other other
: P3 minor with 1 vote (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
: 9945 42040 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-03-24 02:15 UTC by ccikrs1
Modified: 2013-06-01 09:01 UTC (History)
3 users (show)



Attachments
adds variable document length command-line option to apachebench (2.36 KB, patch)
2004-03-24 02:17 UTC, ccikrs1
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ccikrs1 2004-03-24 02:15:52 UTC
Dynamic pages (created with Perl/PHP/... on the fly) rarely have the exact same
byte length for the same URL. Apachebench (src/support/ab), however, registers
this as an error during benchmarking and prints a misleading - and very high -
number of "length errors". I wrote a 5-minute patch that implements a "nolength"
command-line switch to suppress these length errors; I will attach it to this
bug report as soon as I can find the proper button. :)
Comment 1 ccikrs1 2004-03-24 02:17:03 UTC
Created attachment 10937 [details]
adds variable document length command-line option to apachebench
Comment 2 febeling 2007-07-10 02:55:22 UTC
I think it would make more sense not to count varying length resonses as failures at all. A failure would be 
to have a header Content-Length different from the actual length of the response body. 
Comment 3 Christophe JAILLET 2013-06-01 09:00:26 UTC
*** Bug 42040 has been marked as a duplicate of this bug. ***
Comment 4 Christophe JAILLET 2013-06-01 09:01:36 UTC
*** Bug 9945 has been marked as a duplicate of this bug. ***