Bug 27617 - ppt and vsd MIME types should be included in web.xml
ppt and vsd MIME types should be included in web.xml
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Unknown
5.0.19
All other
: P3 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-03-12 01:49 UTC by Scott Pontillo
Modified: 2007-11-29 04:12 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Pontillo 2004-03-12 01:49:54 UTC
Having the following MIME types represented in the default Tomcat web.xml would
be useful:

    <mime-mapping>
        <extension>ppt</extension>
        <mime-type>application/powerpoint</mime-type>
    </mime-mapping>
    <mime-mapping>
        <extension>vsd</extension>
        <mime-type>application/x-visio</mime-type>
    </mime-mapping>
Comment 1 Remy Maucherat 2004-03-12 10:55:08 UTC
Fixed.
Comment 2 Chris Lott 2006-02-27 15:41:17 UTC
The lines in web.xml currently distributed with Tomcat 5.0.28 do not work for
Internet Exploder.  Further, the web.xml file omits an entry for "PPS"
(power-point show) files.

Details: I hit problems while attempting to provide access to powerpoint files
using Tomcat 5.0.28.  That version is distributed with these lines in web.xml:

    <mime-mapping>
        <extension>ppt</extension>
        <mime-type>application/powerpoint</mime-type>
    </mime-mapping>

I compared the mime-types with entries in Apache 2.20 mime.types file,
where I find only this:

    application/vnd.ms-powerpoint        ppt

Based on my tests, Firefox works fine with the application/powerpoint
entry, but IE does not.  IE seems to require the
application/vnd.ms-powerpoint variation, and Firefox accepts that as
well.  I used the following to replace what is shown above with good results:

    <mime-mapping>
        <extension>ppt</extension>
        <mime-type>application/vnd.ms-powerpoint</mime-type>
    </mime-mapping>
    <mime-mapping>
        <extension>pps</extension>
        <mime-type>application/vnd.ms-powerpoint</mime-type>
    </mime-mapping>

Please consider using these entries in the web.xml distributed with Tomcat.

I do not have Visio, so could not test the behavior of IE on a Visio file, but
that probably should be checked as well.

I contacted Scott Pontillo, the original reporter of this bug, and he made the
following suggestion:

>    As a longer-term solution to this problem, maybe it would be good to
>establish a process for importing the entries from the native Apache
>server periodically? It seems they are kept more up-to-date for that
>product...

I've taken it upon myself to reopen the bug since it is easily reproducible and
seems like such a minor issue.  I apologize if this was premature.  Thanks for
listening. 
Comment 3 Keith Wannamaker 2006-03-14 20:15:00 UTC
Fixed in head, thanks.