Bug 23248 - ModuleController doesn't 'remember' module-to-run value when test plan is reloaded.
ModuleController doesn't 'remember' module-to-run value when test plan is rel...
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
1.9.1
PC Linux
: P2 major with 5 votes (vote)
: ---
Assigned To: JMeter issues mailing list
:
: 32684 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-09-18 14:30 UTC by Pete Luellen
Modified: 2005-06-30 09:32 UTC (History)
2 users (show)



Attachments
Comments on a possible weakness in ModuleController.traverse(). (1.17 KB, text/plain)
2004-07-22 11:48 UTC, James Hughes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pete Luellen 2003-09-18 14:30:33 UTC
1.  I created and saved several modules, then opened them in the workbench so
that they would be available to ModuleControllers.

2.. In my test plan, I added several ModuleControllers - each referencing a
different module created in step 1.

3.  Save and close test plan.

4.  Reopen test plan - all ModuleControllers created in step 2 now reference
only one module - the first one listed (alphabetically) in the workbench.
Comment 1 James Hughes 2004-07-22 11:48:36 UTC
Created attachment 12190 [details]
Comments on a possible weakness in ModuleController.traverse().
Comment 2 radish 2005-01-14 08:22:12 UTC
*** Bug 32684 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas Schmid 2005-05-02 08:35:08 UTC
This bug is around since a year and a half and is blocking the user from doing
really modular testing with JMeter.
This is a big issue, if you're doing SOAP tests for example and want to recycle
SOAP calls by putting the into a simple controller and referencing them using
the module controller. Other scenarios can be imagined as well.
Comment 4 Mike Stover 2005-06-30 17:32:45 UTC
Fix checked in.  The module controller will refind the modules it wants at
whatever point you add them (before or after loading the module controller). 
Also, if it can't find it, it will provide a warning about the module it is
expecting to find.