Bug 22510 - SSL Manager does not handle multiple client certificates
SSL Manager does not handle multiple client certificates
Status: RESOLVED DUPLICATE of bug 52033
Product: JMeter
Classification: Unclassified
Component: HTTP
1.9.RC3
PC All
: P3 major with 1 vote (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-08-18 11:51 UTC by Laurent Medioni
Modified: 2011-11-06 23:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Medioni 2003-08-18 11:51:39 UTC
The documentation says:
"13.9.4 SSL Manager
...
The next time you run your test, the SSL Manager will examine your key store to 
see if it has more than one key available to it. If there is only one key, SSL 
Manager will select it for you. If there is more than one key, you will be 
prompted to select the alias you wish to authenticate as.
"

I have a jks file containing several certificates for the required CA and 
JMeter never prompts and always uses the first one...
I tried to remove the first one from my jks and then Jmeter uses the second 
one, and so on...

Is the documentation up to date or is this a bug ?
Comment 1 Jordi Salvat i Alabart 2003-12-04 23:17:17 UTC
Setting correct severity.
Comment 2 Jordi Salvat i Alabart 2004-01-24 11:56:23 UTC
I'm not familiar with the SSL Manager or key stores, but I have the feeling that
this can be easily worked around by using a key store containing only the
desired key. Plus of course correcting the manuals. Can someone who knows
confirm this and possibly fix or downgrade severity to Minor?
Comment 3 Laurent Medioni 2004-01-27 07:45:43 UTC
Yes, it can handle one certificate properly (only the first one unfortunately 
for me).
The documentation has to be corrected if multi-cert is not a feature to be 
retained.
But it would be great to be able to allocate a different certificate (or at 
least a reasonable pool of them) to each thread. Otherwise JMeter does not 
stress test the whole process of authentication because of the various cache 
levels in the systems.
Comment 4 Thomas Fischer 2004-03-30 15:25:26 UTC
I also had a similar problem, and circumvented it by having different 
configuration files (jmeter.properties.xxx) for every certificate, and using 
the different configuration files in different instances of jmeter (starting 
with jmeter -p jmeter.properties.xxx). Of course, this is quite memory-
consuming, but it works.
Comment 5 Sebb 2007-02-21 17:05:04 UTC
This is currently a restriction. The documentation has been updated 
accordingly.
Comment 6 Sebb 2011-10-09 11:47:12 UTC
It would be useful to support multiple certificates at some point
Comment 7 Julian Cesar 2011-11-03 18:29:54 UTC
I believe the solution of this case was implemented in this: https://issues.apache.org/bugzilla/show_bug.cgi?id=52033
Comment 8 Philippe Mouawad 2011-11-06 23:05:39 UTC

*** This bug has been marked as a duplicate of bug 52033 ***