Bug 20242 - LDAP caching does not work without c:\tmp
LDAP caching does not work without c:\tmp
Status: CLOSED DUPLICATE of bug 19304
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ldap
2.0.45
PC All
: P3 major (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-05-26 15:17 UTC by prefab
Modified: 2005-03-20 17:06 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description prefab 2003-05-26 15:17:51 UTC
The caching functionality in mod_ldap does not work in windows systems that do
not have c:\tmp.

This is because the constant MODLDAP_SHMEM_CACHE is hardcoded to point to
/tmp/mod_ldap_cache.

How to reproduce the problem:

configure apache to log errors with debug level. make sure that c:\tmp does not
exist. configure ldap cache in conf. start apache. you should get the following
message in error log:

[Mon May 26 12:16:44 2003] [debug] util_ldap.c(1104): (OS 3)The system cannot
find the path specified.  : [108] ldap cache init: The system cannot find the
path specified.  

stop apache. create c:\tmp. start apache. the file mod_ldap_cache is created in
c:\tmp. you can monitor ldap cache with SetHandler ldap-status.

cheers
prefab
Comment 1 Jess Holle 2003-06-03 11:29:48 UTC
This appears to be a duplicate of bug 19304.
Comment 2 Jess Holle 2003-06-03 11:30:35 UTC
I'd like to suggest that we create this under the logs directory -- like MM 
usages do, etc.
Comment 3 Thom May 2003-06-03 11:34:11 UTC

*** This bug has been marked as a duplicate of 19304 ***