Bug 19329 - [PATCH] Fixes several bugs
[PATCH] Fixes several bugs
Status: CLOSED FIXED
Product: Regexp
Classification: Unclassified
Component: Other
unspecified
All All
: P3 normal (vote)
: ---
Assigned To: Jakarta Notifications Mailing List
:
: 306 1030 3879 4057 5212 10893 14954 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2003-04-25 17:51 UTC by Vadim Gritsenko
Modified: 2004-11-16 19:05 UTC (History)
7 users (show)



Attachments
patch (27.74 KB, patch)
2003-04-25 17:52 UTC, Vadim Gritsenko
Details | Diff
Minor improvement on the previous patch (change in RETest.java) (29.50 KB, patch)
2003-04-25 18:32 UTC, Vadim Gritsenko
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vadim Gritsenko 2003-04-25 17:51:29 UTC
This patch fixes several regexp-1.3-Dev bugs. Those are:
#306  Why is the RE class not Serializable? BugRat Report#559
#1030 {n,m} notation failure in org.apache.regexp.RE.match
#3879 Expressions using {0,n} match 0 to n+1 times instead of 0 to
#4057 \w does not match underscore
#5212 Bracketed space [ \-] followed by dash does not match space

And partially fixes bug
#2121 '.' or '-' in bracket expression gives unexpected results
Because full fix for this bug will change behavior or character classes defined
as [a-] and [-z].

Please apply this patch before 1.3 "final" release.

Thanks,
Vadim
Comment 1 Vadim Gritsenko 2003-04-25 17:52:17 UTC
Created attachment 6017 [details]
patch
Comment 2 Vadim Gritsenko 2003-04-25 17:54:19 UTC
*** Bug 306 has been marked as a duplicate of this bug. ***
Comment 3 Vadim Gritsenko 2003-04-25 17:54:49 UTC
*** Bug 1030 has been marked as a duplicate of this bug. ***
Comment 4 Vadim Gritsenko 2003-04-25 17:55:54 UTC
*** Bug 3879 has been marked as a duplicate of this bug. ***
Comment 5 Vadim Gritsenko 2003-04-25 17:58:53 UTC
*** Bug 4057 has been marked as a duplicate of this bug. ***
Comment 6 Vadim Gritsenko 2003-04-25 17:59:10 UTC
*** Bug 5212 has been marked as a duplicate of this bug. ***
Comment 7 Vadim Gritsenko 2003-04-25 18:19:26 UTC
*** Bug 10893 has been marked as a duplicate of this bug. ***
Comment 8 Vadim Gritsenko 2003-04-25 18:26:36 UTC
*** Bug 14954 has been marked as a duplicate of this bug. ***
Comment 9 Vadim Gritsenko 2003-04-25 18:32:01 UTC
Created attachment 6018 [details]
Minor improvement on the previous patch (change in RETest.java)
Comment 10 Vadim Gritsenko 2003-05-02 01:07:06 UTC
Patch applied