Bug 14827 - JDBCAppender removes list keeps growing
JDBCAppender removes list keeps growing
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Appender
1.2
Other other
: P3 normal
: ---
Assigned To: log4j-dev
:
: 16998 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-11-25 16:30 UTC by John Landers
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Landers 2002-11-25 16:30:22 UTC
Accoding to the source code for JDBCAppender in version 1.2.7
in the method flushBuffer the 'removes' list is never cleared just
gets add called only. So the list will keep expanding.
While the buffer list gets removeAll called so it shrinks.
Needs to add removes.clear after buffer.removeAll(removes).
Otherwise this might be a memory leak.

Do you see the same thing?
Comment 1 Mark Womack 2003-02-19 04:54:41 UTC
*** Bug 16998 has been marked as a duplicate of this bug. ***
Comment 2 Mark Womack 2003-02-19 04:59:33 UTC
Fixed in v1.2.8.  Thank you for the bug and the fix.