Bug 14551 - missing or displaced dtd for XMLayout class
missing or displaced dtd for XMLayout class
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Other
1.2
All other
: P3 normal
: ---
Assigned To: log4j-dev
:
: 17227 18122 30819 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-11-14 12:37 UTC by Wolfgang Brodowski
Modified: 2005-07-28 13:27 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Brodowski 2002-11-14 12:37:10 UTC
the javadoc of the XMLlayout class notices about a DTD, which have to be used 
for validated XML and presents a link to 'doc-files/log4j.dtd', which can not 
be fulfilled out of the api documentation.
Searching around, the missing DTD can be found in the supplied src.zip inside 
the directory /java/org/apache/log4j/xml.
Comment 1 Ralph Nagel 2003-04-10 08:33:23 UTC
This problem occurs also for the XMLSample-file. 
The link on the page 
jakarta-log4j-1.2.8\docs\api\org\apache\log4j\xml\examples\XMLSample.html

refers to 
jakarta-log4j-1.2.8\docs\api\org\apache\log4j\xml\examples\doc-files\sample1.xml

But the files are in
jakarta-log4j-1.1.3\jakarta-log4j-1.1.3\src\java\org\apache\log4j\xml\examples\
Comment 2 Mark Womack 2005-07-01 22:49:15 UTC
1.2.12 candidate

This is just a javadoc change.
Comment 3 Yoav Shapira 2005-07-28 20:32:30 UTC
Fixed for 1.3-alpha7.
Comment 4 Yoav Shapira 2005-07-28 20:42:32 UTC
*** Bug 17227 has been marked as a duplicate of this bug. ***
Comment 5 Yoav Shapira 2005-07-28 20:43:33 UTC
*** Bug 18122 has been marked as a duplicate of this bug. ***
Comment 6 Yoav Shapira 2005-07-28 21:02:06 UTC
*** Bug 30819 has been marked as a duplicate of this bug. ***
Comment 7 Yoav Shapira 2005-07-28 21:27:10 UTC
Fixed on 1.2 branch as well, for 1.2.12rc2.