Bug 11443 - stopping apache 2 triggers reboot
stopping apache 2 triggers reboot
Status: CLOSED DUPLICATE of bug 7932
Product: Apache httpd-2
Classification: Unclassified
Component: mpm_worker
2.0.39
PC All
: P3 normal (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-08-03 13:59 UTC by Martin Schl
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schl 2002-08-03 13:59:16 UTC
If my apache2 server has been running for 'some' time (perhaps an hour) and i
try to stop it with the service monitor, it seems to hang and maybe a minute
after that, my machine reboots.
I can stop apache2 without problems within a few minutes after startup.

Excerpt from my error.log:
[Sat Aug 03 12:31:14 2002] [notice] Parent: Created child process 1660
[Sat Aug 03 12:31:14 2002] [notice] Child 1660: Child process is running
[Sat Aug 03 12:31:15 2002] [notice] Child 1660: Acquired the start mutex.
[Sat Aug 03 12:31:15 2002] [notice] Child 1660: Starting 250 worker threads.
[Sat Aug 03 13:24:21 2002] [notice] Parent: Received shutdown signal -- Shutting
down the server.
[Sat Aug 03 13:24:21 2002] [notice] Child 1660: Exit event signaled. Child
process is ending.
[Sat Aug 03 13:24:22 2002] [notice] Child 1660: Released the start mutex
[Sat Aug 03 13:24:23 2002] [notice] Child 1660: Waiting for 250 worker threads
to exit.
[Sat Aug 03 13:24:51 2002] [notice] Parent: Forcing termination of child process
516 
[Sat Aug 03 13:27:23 2002] [notice] Child 1660: Terminating 1878034896 threads
that failed to exit.
[Sat Aug 03 13:27:23 2002] [notice] Child 1660: All worker threads have exited.
[Sat Aug 03 13:27:23 2002] [notice] Child 1660: Child process is exiting
[Sat Aug 03 13:33:18 2002] [warn] pid file C:/Programme/Apache
Group/Apache2/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?

The above mentioned "unclean shutdown" was of course a reboot.
Interesting detail: 1878034896 seems to be a magic number, because it's always
"1878034896 threads" before my machine reboots.

My machines system protocol contained this (german system):
Der Computer ist nach einem schwerwiegenden Fehler neu gestartet. Der Fehlercode
war: 0x00000076 (0x00000000, 0x8194fc20, 0x00000001, 0x00000000).


Apache used to work on my machine without problems and i didn't touch the
config. I guess, it must have been due to installation/deinstallation of some
other program or windows patch.
The last patch installed a day before trouble started was Windows Hotfix Q318138.

Hope you can help.
Comment 1 William A. Rowe Jr. 2002-08-03 23:57:04 UTC
  Are you using _any_ antivirus or firewall software?  Some, such as 
  ZoneAlarm, are already known to have bad interactions with the Apache
  tcp/ip stack.
Comment 2 Martin Schl 2002-08-04 11:07:20 UTC
Hm, i'm afraid that _might_ be the cause.
I updated my zonealarm a day before the trouble started.
Before i was using Zonealarm 2.6, which worked fine with Apache. But then i
updated to 3.125

Don't know what to do now though. Maybe i should reinstall ZA2.6.

Or is there a workaround to fix the problem?
Comment 3 William A. Rowe Jr. 2002-08-04 16:22:27 UTC

*** This bug has been marked as a duplicate of 7932 ***