Bug 8214

Summary: make fails on Solaris 9 with gcc (atomic/solaris_sparc/*.o not found)
Product: Apache httpd-2 Reporter: Josh Glover <jmglov>
Component: BuildAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED FIXED    
Severity: normal CC: david, quielb, rperrot, schatt, tfan
Priority: P3    
Version: 2.0.35   
Target Milestone: ---   
Hardware: Sun   
OS: Solaris   

Description Josh Glover 2002-04-17 16:27:32 UTC
make bails here:

make[3]: Entering directory
`/homespace/jmglov/medusa/software/httpd-2.0.35/srclib/apr'
/bin/sh /homespace/jmglov/medusa/software/httpd-2.0.35/srclib/apr/libtool
--silent --mode=link gcc -g -O2 -pthreads -DHAVE_CONFIG_H -DSOLARIS2=9
-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I./include -I../include -o libapr.la
-rpath /usr/local/medusa/apache/lib strings/apr_cpystrn.lo
strings/apr_fnmatch.lo strings/apr_snprintf.lo strings/apr_strings.lo
strings/apr_strnatcmp.lo strings/apr_strtok.lo passwd/apr_getpass.lo
passwd/apr_md5.lo tables/apr_hash.lo tables/apr_tables.lo file_io/unix/copy.lo
file_io/unix/dir.lo file_io/unix/fileacc.lo file_io/unix/filedup.lo
file_io/unix/filepath.lo file_io/unix/filestat.lo file_io/unix/flock.lo
file_io/unix/fullrw.lo file_io/unix/mktemp.lo file_io/unix/open.lo
file_io/unix/pipe.lo file_io/unix/readwrite.lo file_io/unix/seek.lo
network_io/unix/inet_ntop.lo network_io/unix/inet_pton.lo
network_io/unix/poll.lo network_io/unix/sendrecv.lo network_io/unix/sockaddr.lo
network_io/unix/sockets.lo network_io/unix/sockopt.lo threadproc/unix/proc.lo
threadproc/unix/procsup.lo threadproc/unix/signals.lo threadproc/unix/thread.lo
threadproc/unix/threadpriv.lo misc/unix/errorcodes.lo misc/unix/getopt.lo
misc/unix/getuuid.lo misc/unix/otherchild.lo misc/unix/rand.lo
misc/unix/start.lo misc/unix/uuid.lo misc/unix/version.lo
locks/unix/crossproc.lo locks/unix/global_mutex.lo locks/unix/intraproc.lo
locks/unix/locks.lo locks/unix/proc_mutex.lo locks/unix/thread_cond.lo
locks/unix/thread_mutex.lo locks/unix/thread_rwlock.lo time/unix/time.lo
time/unix/timestr.lo mmap/unix/common.lo mmap/unix/mmap.lo shmem/unix/shm.lo
i18n/unix/xlate.lo user/unix/groupinfo.lo user/unix/userinfo.lo
memory/unix/apr_pools.lo atomic/solaris_sparc/*.lo dso/unix/dso.lo
ar: cannot open atomic/solaris_sparc/*.o
        No such file or directory
ar: atomic/solaris_sparc/*.o not found
make[3]: *** [libapr.la] Error 1
Comment 1 Joshua Slive 2002-04-20 02:30:10 UTC
*** Bug 8308 has been marked as a duplicate of this bug. ***
Comment 2 Barry Quiel 2002-04-20 05:01:21 UTC
I was attempting to use gcc 3.0.3
Comment 3 Jim Jagielski 2002-04-23 19:03:30 UTC
Please check out the latest head... this should be fixed.
Comment 4 Justin Erenkrantz 2002-04-23 22:30:30 UTC
*** Bug 7839 has been marked as a duplicate of this bug. ***
Comment 5 Justin Erenkrantz 2002-04-23 22:35:29 UTC
*** Bug 8274 has been marked as a duplicate of this bug. ***
Comment 6 Justin Erenkrantz 2002-04-25 00:44:26 UTC
Marking this as fixed.

Please try the latest CVS snapshots or wait for the forthcoming 2.0.36.

Thanks for using Apache!
Comment 7 Joshua Slive 2002-04-27 22:31:48 UTC
*** Bug 8594 has been marked as a duplicate of this bug. ***
Comment 8 Justin Erenkrantz 2002-04-28 07:11:30 UTC
*** Bug 8514 has been marked as a duplicate of this bug. ***