Bug 6663

Summary: Adding trigger class in web app means that the class can not be found
Product: Tomcat 4 Reporter: Bryan Kearney <bk>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 4.0.2 Final   
Target Milestone: ---   
Hardware: PC   
OS: All   

Description Bryan Kearney 2002-02-25 19:29:53 UTC
In my environment, I added a trigger class (e.g. javax.xml.*) in my web app.
This causes the class loader to not find the class at all even if it is
installed in one of the inherited class loaders. If this is added as a jar
file,the jar is skipped but the class could still be found. However, if adding
as a class file it will never be found because findClassInternal() method throws
a ClassNotFoundExeption. 

This ClassNotFound is not intuitive. More intuitive would be what is done with
the jar files, ignore the class in question (with a warning). If the code is
operating according to spec, then more information/docs should be provided as to
the real cause of the exception.
Comment 1 Bryan Kearney 2002-02-25 19:46:38 UTC
Further investigation shows that the javax.xml.* trigger hides the ability for 
the webapp to introduce TRAX logic. The only workaround is to scope this at the 
common class loader
Comment 2 Bryan Kearney 2002-02-25 20:25:11 UTC
Still think this is a bug.
Comment 3 Remy Maucherat 2002-02-26 00:36:19 UTC

*** This bug has been marked as a duplicate of 6374 ***