Bug 6456

Summary: Ant does not support Windows XP
Product: Ant Reporter: Andre Kramer <Andre.Kramer>
Component: CoreAssignee: Ant Notifications List <notifications>
Status: RESOLVED FIXED    
Severity: enhancement CC: afuechsel, bjan11, ccalvert, hattila, javastefan, lakshmi_nj, mboni, osamuo, thg, vpatryshev, y.inoue
Priority: P3 Keywords: JDK1.4
Version: 1.4.1   
Target Milestone: ---   
Hardware: Other   
OS: Windows XP   

Description Andre Kramer 2002-02-14 09:41:43 UTC
Ant defaults to Windows 9x behaviour which breaks building the Java Web 
Service developer pack (JWSDP-EA should show that it's simpler to build-cross 
platform Web Services than be limited to one). In Execute.Java at line 229, 
The Windows NT / 2000 logic should have "xp" added. It may be better to make 
the default similar to 2000, rather than 9x, as all future windows OSs could 
be NT decendent. Better still, could Ant pre-configure itself from an config 
file? A quick fix is to include -Dos.name="Windows XP" on the Ant java command 
line. 
 /* Execute.java line 229: */
        else if ( osname.indexOf("indows") >= 0 ) {
            // Determine if we're running under 2000/NT or 98/95
            if ( osname.indexOf("nt") >= 0 || osname.indexOf("2000") >= 0 
/* Add XP case: */
                 || osname.indexOf("xp") >= 0
) {
                // Windows 2000/NT
                String[] cmd = {"cmd", "/c", "set" };
                return cmd;
            }
            else {
                // Windows 98/95 - need to use an auxiliary script
                String[] cmd = {"command.com", "/c", "set" };
                return cmd;
            }
        }
Comment 1 Conor MacNeill 2002-02-14 12:11:02 UTC
The code in this area has been reworked to support XP. Please try a recent
nightly build.
Comment 2 Stefan Bodewig 2002-02-14 17:43:51 UTC
*** Bug 6471 has been marked as a duplicate of this bug. ***
Comment 3 Steve Loughran 2002-03-11 05:43:05 UTC
*** Bug 7016 has been marked as a duplicate of this bug. ***
Comment 4 Stefan Bodewig 2002-03-11 08:11:39 UTC
*** Bug 7006 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Bodewig 2002-03-25 08:29:10 UTC
*** Bug 7427 has been marked as a duplicate of this bug. ***
Comment 6 Steve Loughran 2002-03-26 01:40:56 UTC
*** Bug 6484 has been marked as a duplicate of this bug. ***
Comment 7 Stefan Bodewig 2002-04-10 08:58:40 UTC
*** Bug 7911 has been marked as a duplicate of this bug. ***
Comment 8 Conor MacNeill 2002-04-14 23:25:56 UTC
*** Bug 8078 has been marked as a duplicate of this bug. ***
Comment 9 Stefan Bodewig 2002-04-18 06:58:11 UTC
*** Bug 8238 has been marked as a duplicate of this bug. ***
Comment 10 Steve Loughran 2002-04-22 21:29:26 UTC
*** Bug 8380 has been marked as a duplicate of this bug. ***
Comment 11 Steve Loughran 2002-05-12 20:40:49 UTC
*** Bug 9010 has been marked as a duplicate of this bug. ***
Comment 12 Ming Aik 2002-06-07 07:18:07 UTC
Where is the Execute.Java stored?
Comment 13 Conor MacNeill 2002-06-15 00:30:03 UTC
*** Bug 9886 has been marked as a duplicate of this bug. ***