Bug 49424

Summary: Using URL.ChunkedStreamingMode results in HTTP response code: 405
Product: Tomcat 5 Reporter: Earl Nolan <earl.nolan>
Component: CatalinaAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: regression    
Priority: P2    
Version: 5.5.29   
Target Milestone: ---   
Hardware: Sun   
OS: Solaris   
Attachments: TestNG unit test to demonstrate the issue.
TestNG unit test to demonstrate the issue.

Description Earl Nolan 2010-06-10 14:08:48 UTC
Using the URL class coupled with setChunkedStreamingMode  results in:

SEVERE: java.lang.NullPointerException
	at org.apache.catalina.connector.Request.readChunkedPostBody(Request.java:2632)

This is true for 6.0.26.  This worked fine in 6.0.16 and the source code
that I have for 6.0.20 does not have the readChunkedPostBody method.

Attached is a TestNG unit test demonstrating the issue.  The method
connectNoChunking() runs fine while the method connectWithChunking() fails.
Comment 1 Earl Nolan 2010-06-10 14:10:14 UTC
Created attachment 25578 [details]
TestNG unit test to demonstrate the issue.
Comment 2 Mark Thomas 2010-06-10 15:22:11 UTC
The header in the test case is not compatible with the Apache License v2. Please confirm how you intended this test case to be licensed.
Comment 3 Earl Nolan 2010-06-10 15:42:04 UTC
(In reply to comment #2)
> The header in the test case is not compatible with the Apache License v2.
> Please confirm how you intended this test case to be licensed.

Sorry about that, our standard header.  I'll upload the file without
the header and release all rights to the test case.
Comment 4 Earl Nolan 2010-06-10 15:42:46 UTC
Created attachment 25579 [details]
TestNG unit test to demonstrate the issue.
Comment 5 Mark Thomas 2010-06-10 16:00:43 UTC
Thanks. I've converted this to a Tomcat unit test and confirmed the problem.

I've fixed the bug in trunk and proposed the fix for 6.0.x
Comment 6 Earl Nolan 2010-06-10 17:49:07 UTC
(In reply to comment #5)
> Thanks. I've converted this to a Tomcat unit test and confirmed the problem.
> 
> I've fixed the bug in trunk and proposed the fix for 6.0.x

Excellent!

Any visibility on when the next point release might be?

We would like to upgrade, this is a blocker for us, and we will not be able
to upgrade during the middle of the football season.
Comment 7 Mark Thomas 2010-06-10 18:02:40 UTC
Current plans are to start the 6.0.27 release process on Monday next week. Depending on how that goes the there could be a release by the end of next week or it could take several weeks to get to a stable release.
Comment 8 Konstantin Kolinko 2010-06-17 12:28:37 UTC
Proposed for 5.5 as well.

Fixed in 6.0 in r955665 and will be in 6.0.28 and later.
Note, that 6.0.27 does not include the fix.
Comment 9 Mark Thomas 2010-06-22 07:55:40 UTC
The fix has been applied 5.5.x and will be included in 5.5.30 onwards.