Bug 47817

Summary: Use multiple connections per thread
Product: JMeter Reporter: jvangaalen
Component: HTTPAssignee: JMeter issues mailing list <issues>
Status: RESOLVED DUPLICATE    
Severity: enhancement CC: p.mouawad, pm
Priority: P2    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: All   

Description jvangaalen 2009-09-10 08:30:17 UTC
As a standard for HTTP/1.1 the browser can use 2 simultaneous connections to the server to do its requests. Currently a single threads seems to use just only one connections to the server. To make testing more realistic a thread / user should be able to use 2 simultaneous connections to retrieve objects.

For the latest versions of Firefox it is even using up to 6 connections simultaneously. To make tests realistic, this woould definitly be a must. Especially for HTTPS it is more realistic because it involves SSL handshakes. Also many webservers are configured to hold a maximum of X connections, and when simultaneous connetions are used you would hit this twice as fast as when testing with only 1 connection (as JMeter does now).
Comment 1 Peter Martinovic 2010-11-08 05:52:05 UTC
We consider this feature very important, e.g. AJAX/GWT pages that execute commands in parralel cannot be now precisely simulated with JMeter. Commands that usually occur in conflicting times, JMeter executes sequentially.
Comment 2 Philippe Mouawad 2012-04-28 14:48:53 UTC
First Requirement has been implemented as Concurrent Download.
I will open a new Bug for second issue

*** This bug has been marked as a duplicate of bug 50943 ***