Bug 43127

Summary: Tomcat's windows service doesn't start up when run in guest OS in MS Virtual Server
Product: Tomcat 5 Reporter: Bogdan <bdziedzic>
Component: UnknownAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED DUPLICATE    
Severity: critical    
Priority: P2    
Version: 5.5.23   
Target Milestone: ---   
Hardware: Other   
OS: Windows XP   

Description Bogdan 2007-08-14 23:43:07 UTC
Setup:Host Win XP SP2 or Win 2k3 st SP2, MS Virtual Sever 2005 R2 SP1 and guest
OS  Win XPSP2 or Win 2k3 St SP2. The host and the client are clean OS -
especially installed for that purpose and default options are selected in MS VS.
One more thing, in guest OS there is Sun JDK 1.6

Description:
Tomcat (apache-tomcat-5.5.23.exe) downloaded from your website and installed by
selecting "next" and "next" in the installer(Sun JRE was found and Tomcat
installed in c:\tomcat). The service is visible in mms service console. 

If you go to the Start menu and select Monitor Tomcat and try to start the
service, the service window will disapire but the service will not start up.
In the same time in Event Viewer in System is recoded:
"The Apache Tomcat service terminated with service-specific error 0 (0x0)"

jakarta_service*.log is recoded:
[2007-08-06 15:46:10] [info] Service JIRA060807154537 name Atlassian JIRA
Enterprise Edition 3.10
[2007-08-06 15:46:10] [info] Service JIRA060807154537 installed
[2007-08-06 15:46:10] [info] Procrun finished.
[2007-08-06 15:46:11] [info] Updating service...
[2007-08-06 15:46:11] [info] Service JIRA060807154537 updated
[2007-08-06 15:46:11] [info] Update service finished.
[2007-08-06 15:46:11] [info] Procrun finished.
[2007-08-06 15:46:11] [info] Updating service...
[2007-08-06 15:46:11] [info] Service JIRA060807154537 updated
[2007-08-06 15:46:11] [info] Update service finished.
[2007-08-06 15:46:11] [info] Procrun finished.
[2007-08-06 15:46:13] [info] Running Service...
[2007-08-06 15:46:13] [info] Starting service...
[2007-08-06 15:46:13] [173 javajni.c] [error] The specified module could not be
found.
[2007-08-06 15:46:13] [924 prunsrv.c] [error] Failed creating java
C:\java\jre1.6.0_01\bin\client\jvm.dll
[2007-08-06 15:46:13] [1179 prunsrv.c] [error] ServiceStart returned 1
[2007-08-06 15:46:13] [info] Run service finished.
[2007-08-06 15:46:13] [info] Procrun finished.

The problem seems to be specific for this implementation as if I use the same OS
(install CD) in Vmware Server it works OK.

Since the virtualisations products getting more and more popular, especially in
hosting environments and the Microsoft solution is one of a popular one, I
though that I let you know.

Regards,
Comment 1 Bogdan 2007-08-15 15:19:44 UTC
The log is taken for an Atlassian application, which uses a customized Tomcat
installer to install the service. Exactly the same output is in the Tomcat's 
log file.
Comment 2 Mark Thomas 2007-08-16 17:05:14 UTC
This is a JVM bug

*** This bug has been marked as a duplicate of 41538 ***