Bug 40633

Summary: DefaultContext tag still referenced in doc.
Product: Tomcat 5 Reporter: Chuck Caldarale <chuck.caldarale>
Component: Webapps:DocumentationAssignee: Tomcat Developers Mailing List <dev>
Status: RESOLVED FIXED    
Severity: minor CC: ben.dilley
Priority: P5    
Version: 5.5.18   
Target Milestone: ---   
Hardware: All   
OS: All   

Description Chuck Caldarale 2006-09-28 17:53:19 UTC
The <DefaultContext> tag is still referenced in several places in the Tomcat
doc, even though it has been replaced by the conf/context.xml file.  I've found
references in the following doc source files:

container/webapps/docs/jndi-resources-howto.xml
container/webapps/docs/config/context.xml
container/webapps/docs/config/engine.xml
container/webapps/docs/config/globalresources.xml
container/webapps/docs/config/host.xml
container/webapps/docs/funcspecs/mbean-names.xml

This problem also exists in the recent 5.5.20 release.
Comment 1 Mark Thomas 2006-09-29 17:24:19 UTC
Fixed in SVN and will be included in 5.5.21 onwards. NB the docs on the website
are aligned with the latest stable release so they will be upadted at the next
release.
Comment 2 Mark Thomas 2007-03-02 04:18:32 UTC
*** Bug 41740 has been marked as a duplicate of this bug. ***
Comment 3 Ben Dilley 2007-03-07 08:55:19 UTC
How do you define default contexts for auto-deployed apps in multiple vhosts,
where each vhost requires different defaults?
Comment 4 Chuck Caldarale 2007-03-07 09:22:44 UTC
RTFM:
http://tomcat.apache.org/tomcat-5.5-doc/config/context.html

In addition to nesting Context elements inside a Host element, you can also
store them:
    * in the individual $CATALINA_HOME/conf/context.xml file: the Context
element information will be loaded by all webapps
    * in the individual
$CATALINA_HOME/conf/[enginename]/[hostname]/context.xml.default file: the
Context element information will be loaded by all webapps of that host
    * in individual files (with a ".xml" extension) in the
$CATALINA_HOME/conf/[enginename]/[hostname]/ directory
    * if the previous file was not found for this application, in individual
file at /META-INF/context.xml inside the application files

Note the 2nd bullet.