Bug 37866

Summary: NTEventLogAppender.dll not built, tested and placed in distribution
Product: Log4j Reporter: Curt Arnold <carnold>
Component: AppenderAssignee: log4j-dev <log4j-dev>
Status: RESOLVED FIXED    
Severity: normal CC: jason.interlichia, tubaman
Priority: P2    
Version: 1.2   
Target Milestone: ---   
Hardware: Other   
OS: other   

Description Curt Arnold 2005-12-12 01:52:32 UTC
NTEventLogAppender.dll which provides access to the Win32 Event Log API methods
used by NTEveltLogAppender.java was built with a BAT file and required a
Microsoft compiler.  This enhancement adds a build.nt target to build.xml using
MinGW, adds a simple test to the test suite and adds the generated DLL to the
distribution.

The Microsoft Message Compiler (mc.exe) and MinGW need to be available on the
path.  The message compiler is available in the Platform SDK as well as Visual
Studio.
Comment 1 Curt Arnold 2005-12-12 02:10:47 UTC
Also added version info to the dll.
Comment 2 Curt Arnold 2006-01-27 20:12:00 UTC
In rev 372945 (trunk) and 372949 (branches/v1_2-branch) committed output of
Microsoft Message Compiler compilation of EventLogCategories.mc into
src/java/org/apache/log4j/nt which allows building NTEventLogAppender.dll
without having the Microsoft Platform SDK on the path, only MinGW is needed.

If changes need to be made to EventLogCategories.mc, to regenerate
EventLogCategories.rc, .h and MSG00001.bin, run "update.nt.msg" and commit changes.
Comment 3 Curt Arnold 2006-04-27 22:49:52 UTC
*** Bug 38203 has been marked as a duplicate of this bug. ***
Comment 4 Curt Arnold 2006-04-27 22:50:18 UTC
*** Bug 38204 has been marked as a duplicate of this bug. ***