Bug 36722

Summary: Load testing error message using Jmeter
Product: JMeter Reporter: Greece <greece.sun>
Component: HTTPAssignee: JMeter issues mailing list <issues>
Status: RESOLVED INVALID    
Severity: normal Keywords: ErrorMessage
Priority: P2    
Version: 2.0.3   
Target Milestone: ---   
Hardware: PC   
OS: Windows 2000   

Description Greece 2005-09-20 07:04:21 UTC
I made use of Jmeter 2.0.3 to do load tesing about our web applications
But there appears the error message:
 
java.io.IOException: Stream closed
at java.io.BufferedInputStream.ensureOpen(BufferedInputStream.java:120)
at java.io.BufferedInputStream.read(BufferedInputStream.java:270)
at java.io.FilterInputStream.read(FilterInputStream.java:90)
at org.apache.jmeter.protocol.http.sampler.HTTPSampler.readResponse
(HTTPSampler.java:263)
at org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample
(HTTPSampler.java:496)
at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample
(HTTPSamplerBase.java:590)
at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample
(HTTPSamplerBase.java:578)
at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:281)
at java.lang.Thread.run(Thread.java:536)
 
Could you help me :
1.what causes the problem?
2.how can I resolve it?
Comment 1 Sebb 2005-09-20 12:20:09 UTC
1) This appears to be caused by the server - check the server logs
2) Fix the broken server!
Comment 2 Sebb 2005-09-20 12:20:40 UTC
1) This appears to be caused by the server - check the server logs
2) Fix the broken server! Or reduce the number of threads
Comment 3 Greece 2005-09-21 05:34:29 UTC
Which server?
DataBase server or Ap server or any other?

(In reply to comment #1)
> 1) This appears to be caused by the server - check the server logs
> 2) Fix the broken server!