Bug 26938

Summary: Interrupted Installation
Product: Apache httpd-2 Reporter: P Conheady <pcweirdo>
Component: Win32 MSI InstallerAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: RESOLVED FIXED    
Severity: blocker CC: bluecat, bugmenot, eddiearmeen, grayson82, neoyorkcity, sfzhi, steve.hay, tmcbeth
Priority: P5    
Version: 2.2.6   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Attachments: MSI Installer Logfile (stops at package code)
MSI verbose log for 2.0.54.
MSI log for failed install of 2.0.55
Error log for msiexec apache_2.0.55-win32-x86-no_ssl
MSI log for failed install of 2.0.55
Error log file for installing 2.2.4 version

Description P Conheady 2004-02-14 06:44:39 UTC
I downloaded apache_2.0.48-win32-x86-no_ssl.msi from apache.org. When I ran 
it, after I'd typed in what it asked for, it started installing. But then it 
said "Installation Interrupted". No idea what's going on.

-Patrick.
Comment 1 Joshua Slive 2004-07-12 18:06:01 UTC
Could you try with the most recent version, and then see
http://www.apache.org/dist/httpd/binaries/win32/TROUBLESHOOTING.html
if you still have problems.
Comment 2 P Conheady 2004-07-14 10:53:09 UTC
I now understand my problem. I had the installer binary on "P:", which was 
created using the SUBST command in Windows. Since "P:" does not actually 
exist, and is really just an alias for c:\pat, the installer thought that P: 
had zero free space. It ran the installer from c:\pat\apache_2.0.48-win32-x86-
no_ssl.msi and it worked fine.

-pcweirdo.
Comment 3 King Kong 2005-04-09 17:04:53 UTC
I'v tried installing from various locations on HD, but I keep getting the
Interruped Install eror. 
OS : Win XP SP2
Comment 4 King Kong 2005-04-20 17:57:48 UTC
I get the Installation interrupted error with 2.0.54 as well
Comment 5 F. Meyer 2005-05-16 09:19:22 UTC
Created attachment 15041 [details]
MSI Installer Logfile (stops at package code)

I have no Idea why the MSI installer stops. There is no error message that
gives a hint. My free disk space ist 181 MB - quite small but that is not the
reason.
Comment 6 Ville Alasaari 2005-05-22 17:41:28 UTC
Created attachment 15118 [details]
MSI verbose log for 2.0.54.

I too have tried to install Apache 2.0.54 to Windows XP Pro SP2.
The Installer always interrupted installation.
But I managed to install 2.0.50... No errors on that.

Then I created log files from these both installations and found these from
them:

2.0.50:
MSI (c) (E8:80) [19:02:20:200]: Product installation will be elevated because
user is admin and product is being installed per-machine.
MSI (c) (E8:80) [19:02:20:200]: Running product
'{3A862C7D-0504-48BC-AEF8-7F7479C7C158}' with elevated privileges: Product is
assigned.

2.0.54:
MSI (c) (24:0C) [19:00:03:464]: Running product
'{3A862C7D-0504-48BC-AEF8-7F7479C7C158}' with user privileges: It's not
assigned.

So to me it looks like the 54 does not detect the privileges right or something
like that?
Comment 7 Andre Victor 2005-05-30 22:29:45 UTC
Same error here, with version 2.0.54 in Windows XP SP2 running as admin. The 
installer gives no option other than Finish, the error record was: "Product: 
Apache HTTP Server 2.0.54 -- Installation operation failed.". Old versions 
installed fine.

Without zip archives with the binaries, i don't see how to install Apache.. 
unless building it from the sources.
Comment 8 eddie 2005-06-02 18:45:48 UTC
in the logs they both have this:

Action ended 19:00:13: ResolveServerName. Return value 3.

looking at the source for ResolveServerName it only ever returns ERROR_SUCCESS 
( Which is 0 ) - so where did this 3 come from?  I think it is from windows and 
the standard windws error number 3 = "file not found".  The ResolveServerName 
is a dll inside the msi call real_features.dll which is extracted to the temp 
dir during the install (to a possibly random name).

so either there is a problem extracting the dll or there is a problem reading 
the dll - to me this means a permissions issue or some other issue with the 
temp dir.

can you try clearing out the temp dir and try again, then download filemon 
(http://www.sysinternals.com/ntw2k/source/filemon.shtml) and filter this to 
show only ERRORS from msiexec.exe.

can you attach the filemon log and the msilog ( /L*v )of this?

Comment 9 Andre Victor 2005-06-04 06:36:02 UTC
The error log was (only the non-SUCCESS entries):

msiexec.exe:1588	OPEN	C:\WINXP\TEMP\MSI7D.TMP	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:1588	OPEN	C:\WINXP\TEMP\MSI7D.TMP	NOT FOUND
	Options: Open  Access: Execute	
msiexec.exe:1588	OPEN	C:\WINXP\AppPatch\systest.sdb	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:1588	OPEN	C:\WINXP\system32\SHELL32.dll.124.Manifest
	NOT FOUND	Options: Open  Access: All	
msiexec.exe:1588	OPEN	C:\WINXP\system32\SHELL32.dll.124.Config
	NOT FOUND	Options: Open  Access: All	
msiexec.exe:1588	QUERY	C:\WINXP\System32\msiexec.exe.Local\	NOT 
FOUND	Attributes: Error	
msiexec.exe:1588	OPEN	C:\WINXP\WindowsShell.Config	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:1588	QUERY	C:\WINXP\System32\msiexec.exe.Local\	NOT 
FOUND	Attributes: Error	
msiexec.exe:1588	QUERY	C:\WINXP\Temp\24da2e6.msi	NOT FOUND
	Attributes: Error	
msiexec.exe:1588	QUERY	C:\WINXP\system32\MSCOREE.DLL.local	NOT 
FOUND	Attributes: Error	
msiexec.exe:1588	OPEN	C:\WINXP\System32\msiexec.config	NOT 
FOUND	Options: Open  Access: All	
msiexec.exe:576	OPEN	C:\WINXP\AppPatch\systest.sdb	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:576	OPEN	C:\WINXP\system32\MsiExec.exe.Manifest	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:576	OPEN	C:\WINXP\system32\MsiExec.exe.Config	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:812	OPEN	C:\WINXP\TEMP\MSI7D.TMP	NOT FOUND	Options: Open  
Access: All	
msiexec.exe:812	OPEN	C:\WINXP\TEMP\MSI7D.TMP	NOT FOUND	Options: Open  
Access: Execute	
msiexec.exe:812	OPEN	C:\WINXP\AppPatch\systest.sdb	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:812	OPEN	C:\WINXP\system32\SHELL32.dll.124.Manifest	NOT 
FOUND	Options: Open  Access: All	
msiexec.exe:812	OPEN	C:\WINXP\system32\SHELL32.dll.124.Config	NOT 
FOUND	Options: Open  Access: All	
msiexec.exe:812	QUERY	C:\WINXP\system32\MsiExec.exe.Local\	NOT FOUND
	Attributes: Error	
msiexec.exe:812	OPEN	C:\WINXP\WindowsShell.Config	NOT FOUND
	Options: Open  Access: All	
msiexec.exe:812	QUERY	C:\WINXP\system32\MsiExec.exe.Local\	NOT FOUND
	Attributes: Error	

Btw, i tried to install the Apache 1.3.33 release and the same happened. I had 
to build the 2.x myself, seems like i will have to do the same for 1.3. If the 
binaries could be distributed in zip files as before, anyways..
Comment 10 Andre Victor 2005-06-04 08:06:32 UTC
Forgot to include the msi log:

    Action 22:47:14: SetupInitialization. Dialog created
    Action ended 22:47:14: SetupInitialization. Return value 1.
    Action start 22:47:14: FindRelatedProducts.
    Action ended 22:47:14: FindRelatedProducts. Return value 1.
    Action start 22:47:14: ResolveServerName.
    MSI (c) (FC:F4) [22:47:14:109]: Creating MSIHANDLE (1) of type 790542 for 
thread 1524
    MSI (c) (FC:CC) [22:47:14:421]: Closing MSIHANDLE (1) of type 790542 for 
thread 1524
    Action ended 22:47:14: ResolveServerName. Return value 3.
    Action start 22:47:14: SetupCompleteError.
    Action 22:47:14: SetupCompleteError. Dialog created
    Action ended 22:47:14: SetupCompleteError. Return value 2.
    Action ended 22:47:14: INSTALL. Return value 3.

    Property(C): RESOLVED_WINSOCK2 = 1
    
    Property(C): SERVERPORT = 80
    Property(C): SERVICEINTERNALNAME = Apache2
    Property(C): SERVICENAME = Apache2
 
 
Seems like ResolveServerName() ran fine but couldn't fill the SERVER* 
properties - but yeah, it should always return ERROR_SUCCESS, the return value 
3 (ERROR_PATH_NOT_FOUND) makes no sense. SetupInitialization() returned 1 
(ERROR_INVALID_FUNCTION), i've no idea what is going on..
Comment 11 eddie 2005-06-06 12:09:27 UTC
ok I was slightly wrong saying the errors mapped to win32 errors, the return 
value 1 means success and 3 means fatal error (from testing pretty much 
anything other than the app returning error_success) see msdn 
(http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/msi/setup/normal_logging.asp) for full details of this.

But the setup is still having a problem either finding or running the 
ResolveServerName and there is this in the filemon log:

msiexec.exe:812	OPEN	C:\WINXP\TEMP\MSI7D.TMP	NOT FOUND	Options: Open  
Access: Execute	

I can't tell for 100% that this file is the real_features_dll because the name 
is randomly generated each time but it does fit.

Have you got any av software or anything else which could be clearing out your 
temp folder?

Also why is "C:\WINXP\TEMP" your temp directory, on XP it is usually in your 
documents and settings? Do you have the TEMP/TMP enviroment variables set?


(In reply to comment #10)
> Forgot to include the msi log:
>     Action 22:47:14: SetupInitialization. Dialog created
>     Action ended 22:47:14: SetupInitialization. Return value 1.
>     Action start 22:47:14: FindRelatedProducts.
>     Action ended 22:47:14: FindRelatedProducts. Return value 1.
>     Action start 22:47:14: ResolveServerName.
>     MSI (c) (FC:F4) [22:47:14:109]: Creating MSIHANDLE (1) of type 790542 
for 
> thread 1524
>     MSI (c) (FC:CC) [22:47:14:421]: Closing MSIHANDLE (1) of type 790542 for 
> thread 1524
>     Action ended 22:47:14: ResolveServerName. Return value 3.
>     Action start 22:47:14: SetupCompleteError.
>     Action 22:47:14: SetupCompleteError. Dialog created
>     Action ended 22:47:14: SetupCompleteError. Return value 2.
>     Action ended 22:47:14: INSTALL. Return value 3.
>     Property(C): RESOLVED_WINSOCK2 = 1
>     
>     Property(C): SERVERPORT = 80
>     Property(C): SERVICEINTERNALNAME = Apache2
>     Property(C): SERVICENAME = Apache2
>  
>  
> Seems like ResolveServerName() ran fine but couldn't fill the SERVER* 
> properties - but yeah, it should always return ERROR_SUCCESS, the return 
value 
> 3 (ERROR_PATH_NOT_FOUND) makes no sense. SetupInitialization() returned 1 
> (ERROR_INVALID_FUNCTION), i've no idea what is going on..

Comment 12 Mikko H 2005-09-20 22:46:23 UTC
Same problem here. WinXP + SP2. So far I've tried 1.3.33 exe and msi installers
packages and 2.0.54 msi installer package. Haven't tried previous versions.
Installation stops before I'm able to select anything.

HOWEVER I've managed to do something that looked like an installation. I tried
msiexec /a installation_package.msi
but had no clue about what it actually did and meant. It just asked me the
location and installed something there. There's some msi-package and a load of
other stuff in that directory. Executing the msi ends up with the well known
result. I feel it just downloaded (or extracted) all the installation stuff
there. At least no new applications were added to the Windows' app list.

Before that I tried these with no effect:
- removing firewall & anti-virus
- granting full permissions to Everyone and SYSTEM on the installation files &
directory paths
- I even changed permissions of 'Documents and Settings\Local Settings\Temp'
- different installation file locations
- installed the very latest installer from Microsoft Downloads
- verified that files are ok

Has anyone (who has further undestanding about the MS Installer) checked the
files that appear in the Temp directory during the installation? There are some
ini files. However I'm not sure they have anything to do with the installation.

My installation log file contains things mentioned above.
Comment 13 Mikko H 2005-09-20 22:48:00 UTC
*** Bug 23967 has been marked as a duplicate of this bug. ***
Comment 14 Mikko H 2005-09-20 22:53:01 UTC
(I have no clue what happened, but I ended up creating a new bug and replying to
a wrong one. Hopefully this comes to the right place!)

Same problem here. WinXP + SP2. So far I've tried 1.3.33 exe and msi installers
packages and 2.0.54 msi installer package. Haven't tried previous versions.
Installation stops before I'm able to select anything.

HOWEVER I've managed to do something that looked like an installation. I tried
msiexec /a installation_package.msi
but had no clue about what it actually did and meant. It just asked me the
location and installed something there. There's some msi-package and a load of
other stuff in that directory. Executing the msi ends up with the well known
result. I feel it just downloaded (or extracted) all the installation stuff
there. At least no new applications were added to the Windows' app list.

Before that I tried these with no effect:
- removing firewall & anti-virus
- granting full permissions to Everyone and SYSTEM on the installation files &
directory paths
- I even changed permissions of 'Documents and Settings\Local Settings\Temp'
- different installation file locations
- installed the very latest installer from Microsoft Downloads
- verified that files are ok

Has anyone (who has further undestanding about the MS Installer) checked the
files that appear in the Temp directory during the installation? There are some
ini files. However I'm not sure they have anything to do with the installation.

My installation log file contains things mentioned above.
Comment 15 Mikko H 2005-11-07 01:43:16 UTC
Installation still interrupted with 1.3.34 and 2.0.55. This bug really bugs me.
Comment 16 William A. Rowe Jr. 2005-11-07 06:24:00 UTC
Folks, if you have encountered this problem...

...are you installing as the administrator?

Have you modified your 'temp' dir location?  Did you grant localsystem
(the \\{machine}\\SYSTEM account} access to this temp location?

Which version of MSI are you using?  Does upgrading to the current microsoft
system installer 3 and using the .msi package (not the self-launching exe)
help you?
Comment 17 Mikko H 2005-11-14 17:42:03 UTC
(In reply to comment #16)
> Folks, if you have encountered this problem...
> ...are you installing as the administrator?
> Have you modified your 'temp' dir location?  Did you grant localsystem
> (the \\{machine}\\SYSTEM account} access to this temp location?
> Which version of MSI are you using?  Does upgrading to the current microsoft
> system installer 3 and using the .msi package (not the self-launching exe)
> help you?
Yes, I tried installation as an administrator. I didn't change temp directory, 
and As I wrote above I've tried to change permissions to every imaginable 
directories. AFAIK WinXP has MSI 3.0 as its default installer. I actually 
tried also version 3.1 which is available from Microsoft Download Center. I 
tried both .exe and .msi. But...

Today I re-installed Windows XP (+SP2) and I believe I've found what was wrong 
with me: F-Secure Anti-Virus. I'm quite sure about it because today I 
installed Windows actually twice. On the first attempt I installed anti-virus 
immediately before installing anything else and installation was interrupted. 
I removed the anti-virus software and it didn't help. So, because I really 
wanted to have Apache installed, I re-installed windows and installed the 
server as the first thing and this time it worked.

Therefore I believe that F-Secure Anti-Virus possibly is doing some nasty 
things which won't be removed although you remove the software.

Windows was installed with a typical setup. On the both times I changed only 
network connection settings.
Comment 18 Ed King 2005-12-09 20:38:55 UTC
Created attachment 17190 [details]
MSI log for failed install of 2.0.55
Comment 19 Ed King 2005-12-09 20:39:11 UTC
I'm encountering this bug as well, on 2.0.53, 2.0.54, and 2.0.55.  It does not
occur at 2.0.52 or lower.

MSIEXEC version: "Windows ® Installer. V 3.01.4000.1823"

I've attached my MSI log file.
Comment 20 William A. Rowe Jr. 2005-12-10 05:25:45 UTC
Comment on attachment 15041 [details]
MSI Installer Logfile (stops at package code)

Corrupted - invalid .log file
Comment 21 William A. Rowe Jr. 2005-12-10 05:36:56 UTC
Comment on attachment 15118 [details]
MSI verbose log for 2.0.54.

Attachment contains garbage
Comment 22 William A. Rowe Jr. 2005-12-10 05:37:09 UTC
Comment on attachment 17190 [details]
MSI log for failed install of 2.0.55

Attachment contains garbage
Comment 23 William A. Rowe Jr. 2005-12-10 06:57:20 UTC
  For some reason all of your .log files showed up with no legible contents.
  Please don't submit unicode (and I doubt you did, but thought I would mention
  it anyways.)  Ensure you can open the file in notepad, and that the uploaded
  log file is still legible.

  The installer should need only 20-30mb free to run, once the package is 
  downloaded, so space doesn't seem to be the issue.

  I'm most interested in seeing your (collective) reactions to the next package
  of 2.2 (and if it's successful, will repackage the last 2.0, 1.3 builds) based
  on moving from InstallShield 10 to 11.5, to see if this clears things up.
  I'll also validate the package in orca.  Once that package is ready, I'll
  update this bug again, with a temporary link to the package.
Comment 24 Noble Lesmana 2005-12-13 19:18:04 UTC
Created attachment 17211 [details]
Error log for msiexec apache_2.0.55-win32-x86-no_ssl

Same error: Installation Wizard Interrupted. Here I attach the log file
generated by the msiexec. Thank you.
Comment 25 Ed King 2005-12-18 01:03:04 UTC
Created attachment 17237 [details]
MSI log for failed install of 2.0.55

Sorry about the corrupted version earlier.  This one should do it.
Comment 26 William A. Rowe Jr. 2006-06-01 06:30:27 UTC
Comment on attachment 17211 [details]
Error log for msiexec apache_2.0.55-win32-x86-no_ssl

Deleting unicode attachment.
Comment 27 Lou Ksh 2007-04-10 00:04:41 UTC
I encountered the same problem while trying to install 2.2.4 and 2.0.59 version.
 Already shut down all antivirus software and firewall and used the latest
Window Installer...but still didn't work.  Don't know what to do.
Comment 28 Lou Ksh 2007-04-10 00:12:44 UTC
Created attachment 19926 [details]
Error log file for installing 2.2.4 version

the log contains some chinese characters

C:\Documents and
Settings\lou\&#12300;&#38283;&#22987;&#12301;&#21151;&#33021;&#34920;\&#31243;&#24335;&#38598;\&#31995;&#32113;&#31649;&#29702;&#24037;&#20855;


which is same as

C:\Documents and Settings\lou\Start Menu\Programs\Administrative Tools
Comment 29 William A. Rowe Jr. 2007-12-21 21:00:30 UTC
*** Bug 33663 has been marked as a duplicate of this bug. ***
Comment 30 William A. Rowe Jr. 2007-12-21 21:03:22 UTC
*** Bug 36593 has been marked as a duplicate of this bug. ***
Comment 31 William A. Rowe Jr. 2007-12-21 21:03:52 UTC
*** Bug 35502 has been marked as a duplicate of this bug. ***
Comment 32 William A. Rowe Jr. 2007-12-21 21:49:30 UTC
*** Bug 42480 has been marked as a duplicate of this bug. ***
Comment 33 William A. Rowe Jr. 2007-12-21 22:11:08 UTC
*** Bug 33898 has been marked as a duplicate of this bug. ***
Comment 34 William A. Rowe Jr. 2007-12-22 16:02:56 UTC
This bug was already a catchall, and continues to be useless.

Those who have encountered problems with WinSock2 and ResolveServerName,
new bug fixes and logging introduced for 2.2.7 coming release will identify
these issues.

Those looking for internationalized paths, that issue is bug  33685
Comment 35 bugmenot 2008-01-06 01:01:37 UTC
2.2.6 is borked too.
Comment 36 William A. Rowe Jr. 2008-01-06 08:10:37 UTC
Update the rev # to the final "borked" flavor that was previously released.

Fixes are to 2.2.7 (2.0.62) or later binary releases as they happen.
Comment 37 William A. Rowe Jr. 2008-01-06 08:12:26 UTC
*** Bug 44174 has been marked as a duplicate of this bug. ***