Bug 21739

Summary: Apache 1.28 creates zombies on OpenBSD 3.2
Product: Apache httpd-1.3 Reporter: Lou Hevly <soc>
Component: OtherAssignee: Apache HTTPD Bugs Mailing List <bugs>
Status: CLOSED DUPLICATE    
Severity: normal    
Priority: P3    
Version: 1.3.28   
Target Milestone: ---   
Hardware: PC   
OS: other   
URL: http://visca.com/apache.html

Description Lou Hevly 2003-07-20 11:02:23 UTC
After successfully upgrading from Apache 1.27 to 1.28, I noticed I started having zombies 
created (20 in 12 hours on a system that gets about 15 K hits per day); restarting apache 
killed the zombies.

The zombies looked like this:
$ ps -waux | grep Z
USER       
PID %CPU %MEM   VSZ   RSS TT   STAT STARTED       TIME COMMAND
visca     1962  0.0  0.0     0     0 
??  ZW    -          0:00.00 (perl)
vpopmail  5013  0.0  0.0     0     0 ??  ZW    -          0:00.00 
(sqwebmail)
upperlef  1962  0.0  0.0     0     0 ??  ZW    -          0:00.00 (perl)
etc.

Basic 
details:
$ uname -a
OpenBSD wh2ds.visca-server.com 3.2 GENERIC#0 
i386

Apache startup notice:
[Sat Jul 19 09:51:25 2003] [notice] 
Apache/1.3.28 (Unix) PHP/4.3.2 mod_perl/1.28 mod_ssl/2.8.15 OpenSSL/0.9.6j 
configured -- resuming normal operations
[Sat Jul 19 09:51:25 2003] [notice] suEXEC 
mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
[Sat Jul 19 09:51:25 
2003] [notice] Accept mutex: sysvsem (Default: sysvsem)

Complete details 
are available at:
http://visca.com/apache.html

Lou
Comment 1 J. Nick Koston 2003-07-20 18:50:00 UTC

*** This bug has been marked as a duplicate of 21737 ***