Create Ticket
Warning Can't synchronize with repository "(default)" (Couldn't open Subversion repository /x1/svn/asf/bloodhound: SubversionException: ("Expected FS format between '1' and '4'; found format '6'", 160043)). Look in the Trac log for more information.

Reporter:
gjm  
Opened:
Type:
enhancement  
Status:
closed : fixed  
Priority:
major  
Milestone:
Component:
Version:
 
Description

To be looked at after #20

The display of the admin's help link for when there is no source repositories available should respect other configuration details that were not specified in #20:

  • The menu item should not be shown if the trac.versioncontrol.web_ui.browser.BrowserModule component is not activated
  • The menu item should not be shown if it is disabled in the mainnav configuration
    • Config to disable the browser:
      [mainnav]
      browser = disabled
      
  • The menu item should use the label specified in the mainnav configuration
    • Example of changing "Browse Source" to "Source":
      [mainnav]
      browser.label = Source
      
  • If possible it would be good to respect the order specified by the configuration
    • Example of setting the order:
      [trac]
      mainnav = browser,wiki,tickets,newticket,timeline,roadmap,search,admin
      
Cc:
 

Change History

gjm

Given the approach taken, I believe this is already covered by #20

gjm

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed.

olemis

  • Milestone set to RC1 for initial release
Note: See TracTickets for help on using tickets.

Activity

  

Warning   No events reported for enhancement: Source Browser main menu item showing for admins part 2 (closed: fixed) in the last 30 days since Apr 19, 2014. This may happen if system is not configured correctly. Please contact your administrator if you think this is the case.