Create Ticket
Warning Can't synchronize with repository "(default)" (Couldn't open Subversion repository /x1/svn/asf/bloodhound: SubversionException: ("Expected FS format between '1' and '4'; found format '6'", 160043)). Look in the Trac log for more information.

Reporter:
olemis  
Opened:
Type:
defect  
Status:
closed : fixed  
Priority:
blocker  
Milestone:
Component:
Version:
 
Description (last modified by olemis) (diff)

I was taking a look at this patch and it looks really bad .

Maybe it is just that Trac's diff.css is gone and not applied anymore ?

Anyway , please take a look identify what happened with that and revert to the previous working state . IMO 0.4.0 should not be released until we fix this issue .

Cc:
olemis+bh@…  

Change History

olemis

  • Cc olemis+bh@… added
  • Description modified (diff)
  • Keywords diff file preview starter added
  • Milestone set to Release 4
  • Priority changed from major to blocker

olemis

  • Keywords regression added
16 months ago

comment:3  

In reply to: ↑ description

Follow-up:

rjollos

Replying to olemis:

Maybe it is just that Trac's diff.css is gone and not applied anymore ?

I can reproduce with the latest version of the trunk. .patch files render fine and diff.css is added to the page, so the problem is only with .diff files. I had thought this was an issue with Trac 1.0, but I wasn't able to reproduce the issue in Trac 1.0.

rjollos

Opened #10709 for the PermRedirectPlugin, which was found during investigation of the issue, though it appears to be unrelated.

16 months ago

comment:5  

In reply to: ↑ 3

olemis

Replying to rjollos:

Replying to olemis:

Maybe it is just that Trac's diff.css is gone and not applied anymore ?

I can reproduce with the latest version of the trunk. .patch files render fine and diff.css is added to the page, so the problem is only with .diff files.

JFTR , aforementioned preview page was opened in my browser since days ago and looking fine . I refreshed it by accident minutes before reporting this issue and it was completely broken , as can be seen . I've not detected the cause though .

I had thought this was an issue with Trac 1.0, but I wasn't able to reproduce the issue in Trac 1.0.

thanks for checking that :)

rjollos

The issue first appears in r1398968 when Trac 1.0 was merged into the trunk.

rjollos

The issue appears to be related to a defect that was introduced just before the release of Trac 1.0. The defect mentioned in comment:22:ticket:5533 seems to only affect the diff WikiProcessor in Trac, a problem that can be reproduced in Bloodhound. However, this Trac defect also appears to affect preview rendering in Bloodhound. Applying the fix in [trac 11319] fixes the issue we see with Bloodhound preview rendering of .diff files, even though this issue is not seen in Trac.

The fix will be included in Trac 1.0.1, so it looks like Bloodhound just needs to wait for that release to get this issue fixed. Though, it would be nice to understand: Why does this defect affect Bloodhound preview rendering but not Trac preview rendering?

When applying or reverting the fix from [trac 11319], I've found it necessary to clear the browser cache in order to see the change takes effect (In Chrome, go to Clear all browsing data > Clear the cache). It is not enough to restart Bloodhound and refresh the browser. This was surprising to me since these measures are not necessary in order to see the effect of the fix on the diff WikiProcessor.

Last edited 16 months ago by rjollos (previous) (diff)

gjm

  • Resolution set to fixed
  • Status changed from new to closed

I think that this will be annoying so I have applied the patch in advance of creating a new vendor branch. Committed in r1429787.

Thanks rjollos!

gjm

  • Owner changed from nobody to rjollos
Note: See TracTickets for help on using tickets.

Activity

  

Warning   No events reported for defect: Diff CSS is gone in i.a.o - after #290 ? (closed: fixed) in the last 30 days since Apr 20, 2014. This may happen if system is not configured correctly. Please contact your administrator if you think this is the case.