Create Ticket

Reporter:
olemis  
Opened:
Type:
enhancement  
Status:
closed : fixed  
Priority:
major  
Milestone:
Component:
Version:
 
Description

Recently Bootstrap 2.1.0 has been released including Affix plugin. In a few words it's a feature quite similar to sticky panels . I recommend to upgrade our copy and distribute that version and use that plugin instead of current solution .

PS: It's not about that ours doesn't work or is broken . It's just that it is convenient to reuse Bootstrap 's supported solution while we focus on other things ;)

Cc:
 

Attachments

t172_r1365626_bootstrap_affix.diff (4.8 KB) - added by olemis 23 months ago.
Patch: BH Theme #172: Including Bootstrap affix plugin
t172_r1365626_bootstrap_affix_ticket.diff (1.0 KB) - added by olemis 23 months ago.
Patch: BH Theme #172: Sticky panels in ticket view powered by Bootstrap affix plugin
t172_r1365626_bootstrap_affix_models.diff (1.1 KB) - added by olemis 23 months ago.
Patch: BH Theme #172: Sticky panels in milestone and product view powered by Bootstrap affix plugin
t172_r1371737_bootstrap_2.1.0.diff.zip (26.8 KB) - added by olemis 23 months ago.
Patch: BH Dashboard #172: Upgrade Bootstrap to version 2.1.0
t172_r1371737_bootstrap_affix_models.diff (1.2 KB) - added by olemis 23 months ago.
Patch: BH Dashboard #172: Sticky panels in models view using Bootstrap affix plugin

Download all attachments as: .zip


Change History

olemis

I've noticed that (at least) typography and breadcrumbs are slightly different in version 2.1.0 . What shall we do about that ?

olemis

Patch: BH Theme #172: Including Bootstrap affix plugin

olemis

Patch: BH Theme #172: Sticky panels in ticket view powered by Bootstrap affix plugin

olemis

Patch: BH Theme #172: Sticky panels in milestone and product view powered by Bootstrap affix plugin

olemis

Patch: BH Dashboard #172: Upgrade Bootstrap to version 2.1.0

olemis

Attached patches implement sticky panels using Bootstrap Affix plugin and some extra magic needed to make it work smoothly. Ticket, milestone and product UI have been updated as well.

Dashboard plugin

Apply the following patches in given order against r1371737

$ hg qapplied
t172/t172_r1371737_bootstrap_2.1.0.diff
t172/t172_r1371737_bootstrap_affix_models.diff

Theme plugin

Apply the following patches in given order against r1365626

$ hg qapplied
t172/t172_r1365626_bootstrap_affix.diff
t172/t172_r1365626_bootstrap_affix_ticket.diff
t172/t172_r1365626_bootstrap_affix_models.diff

23 months ago

comment:3  

In reply to: ↑ 1

jdreimann

Replying to olemis:

I've noticed that (at least) typography and breadcrumbs are slightly different in version 2.1.0 . What shall we do about that ?

I'm happy to just adopt the new 2.1.0 defaults, including the Affix plugin. Our current sticky panel code does seem to be broken by the way, as seen in ticket #88, where you can see it somewhat offset from the top.

olemis

Patch: BH Dashboard #172: Sticky panels in models view using Bootstrap affix plugin

gjm

r1381141 upgrades bootstrap to 2.1.0

r1381143 uses affix plugin for sticky panels

r1381144 changes for including affix plugin

r1381145 provides tweaks for ticket, product and milestone views

gjm

  • Resolution set to fixed
  • Status changed from new to closed

Regression probably due to this noted in #197

Otherwise, this seems fine.

Note: See TracTickets for help on using tickets.

Activity

  

Warning   No events reported for enhancement: Implement sticky panels using Bootstrap affix plugin (closed: fixed) in the last 30 days since Jul 10, 2014. This may happen if system is not configured correctly. Please contact your administrator if you think this is the case.