Bug 6661 - t/spamd_ssl*2* obsolete
t/spamd_ssl*2* obsolete
Status: RESOLVED FIXED
Product: Spamassassin
Classification: Unclassified
Component: Regression Tests
SVN Trunk (Latest Devel Version)
All OpenBSD
: P2 minor
: 3.4.0
Assigned To: SpamAssassin Developer Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-09-19 21:32 UTC by stu-spamassassin-bugzilla
Modified: 2011-09-20 18:34 UTC (History)
1 user (show)



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description stu-spamassassin-bugzilla 2011-09-19 21:32:37 UTC
Bug 6595 removed SSLv2 support from spamd; the regression tests for this in t/spamd_ssl*2* are still present. Besides failing with the illegal sslv2 option, the recent update to Net_SSLeay has removed sslv2 support so they also fail due to missing functions.
Comment 1 Mark Martinec 2011-09-20 12:46:31 UTC
> Bug 6595 removed SSLv2 support from spamd; the regression tests for this in
> t/spamd_ssl*2* are still present. Besides failing with the illegal sslv2
> option, the recent update to Net_SSLeay has removed sslv2 support so they also
> fail due to missing functions.

Indeed. Thanks!

trunk:
  Bug 6661: t/spamd_ssl*2* obsolete, deleted
  to avoid them failing with "spamd: invalid ssl-version"'
Deleting t/spamd_ssl_v2.t
Deleting t/spamd_ssl_v23.t
Committed revision 1173121.
Comment 2 Mark Martinec 2011-09-20 12:47:08 UTC
closing
Comment 3 Kevin A. McGrail 2011-09-20 17:45:13 UTC
I *think* this patch is breaking hudson/jenkins.  

Perhaps just that the test is still listed in the MANIFEST. 

I'm removing the two files from the MANIFEST now and doing a make test.  Will submit and see what happens!

svn commit -m 'removed SSLv2 tests from MANIFEST'
Sending        MANIFEST
Transmitting file data .
Committed revision 1173273.


Test Summary Report
-------------------
t/make_install.t                (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 25 tests but ran 0.
Files=168, Tests=3410, 1512 wallclock secs ( 1.48 usr  0.83 sys + 674.21 cusr 54.74 csys = 731.26 CPU)
Result: FAIL
Failed 1/168 test programs. 0/3410 subtests failed.
*** Error code 29
make: Fatal error: Command failed for target `test_dynamic'
+ mv t/log artifacts/t.log.make_test 
PASTHRU=TEST_VERBOSE=1
+ export PASTHRU 
+ tee artifacts/make_disttest.log 
+ make -e disttest TEST_VERBOSE=1 
rm -rf Mail-SpamAssassin-3.4.0
/export/home/jm/tools/perl586/bin/perl "-MExtUtils::Manifest=manicopy,maniread" \
	-e "manicopy(maniread(),'Mail-SpamAssassin-3.4.0', 'best');"
-e: t/spamd_ssl_v2.t not found at -e line 1
Can't read t/spamd_ssl_v2.t: No such file or directory
Comment 4 Mark Martinec 2011-09-20 17:55:11 UTC
> I *think* this patch is breaking hudson/jenkins.  
> Perhaps just that the test is still listed in the MANIFEST. 
> I'm removing the two files from the MANIFEST now and doing a make test.
> Will submit and see what happens!

Yes, so it seems. Thanks!
Comment 5 Kevin A. McGrail 2011-09-20 18:34:33 UTC
(In reply to comment #4)
> > I *think* this patch is breaking hudson/jenkins.  
> > Perhaps just that the test is still listed in the MANIFEST. 
> > I'm removing the two files from the MANIFEST now and doing a make test.
> > Will submit and see what happens!
> 
> Yes, so it seems. Thanks!

Jenkins build is back to normal : SpamAssassin-trunk #7359