Bug 5872 - body and rawbody rules ignoring attached header in a bounce?
body and rawbody rules ignoring attached header in a bounce?
Status: RESOLVED INVALID
Product: Spamassassin
Classification: Unclassified
Component: Libraries
SVN Trunk (Latest Devel Version)
All All
: P5 minor
: Undefined
Assigned To: SpamAssassin Developer Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2008-04-03 17:13 UTC by Mark Martinec
Modified: 2008-04-06 16:06 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status
sample bounce message text/plain None Mark Martinec [HasCLA]

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Martinec 2008-04-03 17:13:27 UTC
Created attachment 4287 [details]
sample bounce message

I was trying to make a rule matching a particular Message-ID
in a referenced message attached to a bounce message,
but not even the following two simple rules provide any hits
on the attached sample:

body  L_TEST1 /Meds Discount for brocco/
score L_TEST1 1

rawbody L_TEST2 /Meds Discount for brocco/
score L_TEST2 1

Must be a late night hour - or is it for real?
Comment 1 Mark Martinec 2008-04-04 07:34:14 UTC
> in a referenced message attached to a bounce message,
> but not even the following two simple rules provide any hits

Seems like another manifestation of Bug 5331.
Comment 2 Justin Mason 2008-04-06 12:42:16 UTC
actually, I don't think body or rawbody recurse into message/rfc822 attachments by design.  full should do it...
Comment 3 Mark Martinec 2008-04-06 16:06:45 UTC
> actually, I don't think body or rawbody recurse into message/rfc822 attachments
> by design.  full should do it...

You are right, the 'full' does see the string, thanks.
Unfortunately for my purpose it also sees it in the main header section,
not only in the body (attachments), but I guess I'll have to live with it.

So I'll close it as INVALID, it does work as documented.