Bug 4774 - need better way to reload configuration
need better way to reload configuration
Status: RESOLVED DUPLICATE of bug 4914
Product: Spamassassin
Classification: Unclassified
Component: Libraries
SVN Trunk (Latest Devel Version)
Other other
: P5 major
: Undefined
Assigned To: SpamAssassin Developer Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-01-31 20:10 UTC by Justin Mason
Modified: 2006-09-04 05:55 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Mason 2006-01-31 20:10:26 UTC
I've noticed that using the SIGHUP method to reload the configuration, often
seems to allow messages to pass through unscanned while the spamd restarts.

We need a better, less heavyweight method to reload config, instead of a full
daemon stop/restart cycle.
Comment 1 Tom Schulz 2006-01-31 22:31:26 UTC
Check out what Sendmail does.  It disconnects from the children, letting them
live to complete their current job.  When the children finish their current
job and discover that their parent is gone, they exit.  The other thing that
you would need would be for the new daemon to grab the port quickly on startup.
I think that Sendmail may do something fancy so that the new daemon is started
before the old one exits.  Perhaps the Sendmail developer could give you a quick
outline on how he did it.
Comment 2 Justin Mason 2006-09-04 12:55:16 UTC

*** This bug has been marked as a duplicate of 4914 ***