Bug 3933 - Add summary of important config options you should set first.
Add summary of important config options you should set first.
Status: RESOLVED FIXED
Product: Spamassassin
Classification: Unclassified
Component: Documentation
3.0.1
Other All
: P5 enhancement
: 3.2.0
Assigned To: SpamAssassin Developer Mailing List
http://wiki.apache.org/spamassassin/I...
: triage
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2004-10-27 14:12 UTC by Fred T
Modified: 2006-12-12 12:34 UTC (History)
0 users



Attachment Type Modified Status Actions Submitter/CLA Status

Note You need to log in before you can comment on or make changes to this bug.
Description Fred T 2004-10-27 14:12:34 UTC
I think it would be very beneficial to everyone who installs SpamAssassin for 
the first time to have a reference of VERY important config options that should 
be set before using SA for the first time.

I suggest adding something like the following near the top of the docs for 
Mail::SpamAssassin::Conf

It would greatly help anyone who is installing SA for the first time, having 
this information handy would save people time and troubles.

--cut--

Important Settings you should set first

use_bayes (0|1) 0 = no 1 = yes
This enables using Bayes.  Do you want this?, should you use it for your 
application?, make sure you know if you need/want this or not before 
installing. 

use_auto_whitelist (0|1)
This enables using Auto-Whitelist factor.  Read the description above for bayes 
and ask the same questions. 

dns_available (yes|no|test) default = test
This enables or disables using dns (disables network tests if set to no).  
Setting this to no has side effects of turning of a lot of helpful tests.  If 
available always set this to yes. 



If someone installs SA on a new box it is important they know which settings 
are most important to set before using the software.
Comment 1 Theo Van Dinter 2004-10-27 14:14:27 UTC
Subject: Re:  New: Add summary of important config options you should set first.

On Wed, Oct 27, 2004 at 02:12:35PM -0700, bugzilla-daemon@bugzilla.spamassassin.org wrote:
> I think it would be very beneficial to everyone who installs SpamAssassin for 
> the first time to have a reference of VERY important config options that should 
> be set before using SA for the first time.

This sounds like a good wiki document. ;)

Comment 2 Fred T 2004-10-27 14:20:22 UTC
It does but I feel it might slip past the user if it's not included in some way 
in the distro.  You do have the final say over these things, I'm just giving my 
side of the story.

Can we do both?

The problem I have (and possibly others) is that if a doc is not included with 
a distro I feel it must not be important towards the workings of the distro.  
In this case, it's really important that the user knows that AWL and BAYES are 
turned on by default for them and how to turn them off if needed.

How about a file in the distro which provides links to some of the most 
important wiki entries?  This might make it easier for the devs to maintain and 
help out the users at the same time.
Comment 3 Fred T 2004-10-27 14:21:50 UTC
The information is available in the Mail::SpamAssassin::Conf docs but I feel 
the problem is due to the size of that file the information does not jump out 
at you.
Comment 4 Justin Mason 2004-10-27 14:41:40 UTC
would make a great Wiki page, and it'd be fine to place a VERY prominent link to
that in the POD I think.

the POD as it stands is too verbose -- adding more text won't help.  A better
way to deal with the problem is to have a wiki page that takes the user's point
of view.
Comment 5 Justin Mason 2006-10-19 07:08:43 UTC
if someone writes the page, I'll link to it from the docs.
Comment 6 Fred T 2006-12-08 10:36:44 UTC
I started a rough draft, please anyone with more insight, feel free to update
this page:

http://wiki.apache.org/spamassassin/ImportantInitialConfigItems
Comment 7 Justin Mason 2006-12-12 12:34:24 UTC
checked in.  the page could do with work though...