Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-14996 Some more API cleanup for 2.0
  3. HBASE-14998

Unify synchronous and asynchronous methods in Admin and cleanup

    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Resolved
    • Blocker
    • Resolution: Fixed
    • None
    • 2.0.0-alpha-3, 2.0.0
    • None
    • None
    • Reviewed
    • Hide
       * Deprecates getAlterStatus. Everywhere else we talk of 'modify' rather
             'alter' and should use Future returned from async instead.
       * isTableAvailable(TableName, byte [][]) has been deprecated to be
             removed; use the overrie instead. This is a weird method.
       * Changed listTableDescriptor to getDescriptor.
       * Renamed other like methods to have same pattern (deprecating the old):
              balancer => balance
              setBalancerRunning => balancerSwitch
              setNormalizerRunning => normalizerSwitch
              enableCatalogJanitor => catalogJanitorSwitch
              setCleanerChoreRunning => cleanerChoreSwitch
              setSplitOrMergeEnabled => splitOrMergeEnabledSwitch

       * Renamed (with deprecation of old) runCatalogScan => runCatalogJanitor.
       * Reviewed generated javadoc and made some edits; purged reference to
             hbase issues from our API, fixed param names, etc.
       * Made all the enable services methods have same pattern.
       * Renamed takeSnapshotAsync as snapshotAsync (with deprecation of old)
       * Renamed execProcedureWithRet as execProcedureWithReturn (with
             deprecation)
      Show
       * Deprecates getAlterStatus. Everywhere else we talk of 'modify' rather        'alter' and should use Future returned from async instead.  * isTableAvailable(TableName, byte [][]) has been deprecated to be        removed; use the overrie instead. This is a weird method.  * Changed listTableDescriptor to getDescriptor.  * Renamed other like methods to have same pattern (deprecating the old):         balancer => balance         setBalancerRunning => balancerSwitch         setNormalizerRunning => normalizerSwitch         enableCatalogJanitor => catalogJanitorSwitch         setCleanerChoreRunning => cleanerChoreSwitch         setSplitOrMergeEnabled => splitOrMergeEnabledSwitch  * Renamed (with deprecation of old) runCatalogScan => runCatalogJanitor.  * Reviewed generated javadoc and made some edits; purged reference to        hbase issues from our API, fixed param names, etc.  * Made all the enable services methods have same pattern.  * Renamed takeSnapshotAsync as snapshotAsync (with deprecation of old)  * Renamed execProcedureWithRet as execProcedureWithReturn (with        deprecation)

    Description

      Admin has a bunch of methods, some are asnyc, some are sync. Needs some unification in method naming, and method signatures.

      • We use modify and alter interchangeably. Pick one and stick with it (modifyTable(), versus getAlterStatus()). Shell uses alter.
      • Remove getAlterStatus(), should not be needed.
      • remove already deprecated methods
      • isTableAvailable(TableName tableName, byte[][] splitKeys) should be removed.
      • Consistently use Aysnc as a prefix for all async methods.
      • Other ideas?

      Attachments

        1. 14998.txt
          2 kB
          Michael Stack
        2. HBASE-14998.master.001.patch
          112 kB
          Michael Stack
        3. HBASE-14998.master.002.patch
          112 kB
          Michael Stack
        4. HBASE-14998.master.003.patch
          112 kB
          Balazs Meszaros
        5. HBASE-14998.master.003.patch
          112 kB
          Michael Stack

        Activity

          People

            meszibalu Balazs Meszaros
            enis Enis Soztutar
            Votes:
            0 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: